Search Discussions:


Showing results for 
Search instead for 
Do you mean 
Advanced search
Welcome to our community! Here you can share advice and tips with thousands of other Microsoft mobile devices users around the world in English. Please take a moment to read our community guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others you need to sign in first. If this is your first time here, you can choose an alias to represent you. If you don't have an account yet, please register here.
Reply

Can´t restart my 2760

New Member
sulviking
Posts: 2

Can´t restart my 2760

I have to shut down my 2760 when I was at a hospital.

But now I can not restart it.

It begin to start but gives me a blank display for a few (5-7)secunds, then it go to a dark mode whitout any light on the display.

I try to connect the charger but nothing shows on the display

it never comes to where i can enter the pin code

 

Anyone know what to do??

Mobile Guru
mccbleue
Posts: 4,145

Re: Can´t restart my 2760

It could be as simple as the battery being drained, habve you tried charging it?

 

Assuling that you have, the only ting you can do with an S40 model like this is to take it to a Nokia service point, there isn't anything you'd be able to do to revive it yourself.

New Member
sulviking
Posts: 2

Re: Can´t restart my 2760

I thougt so to, but i switched my battery with my girlfriend who has the same phone type.
And it was the same result
I also tryed to disconnect battery for 5 min, -no result
but anyhow, thanx for the answer