Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: CDC Comms Interface Drivers

Registered Member
supercxl
Posts: 1

Re: CDC Comms Interface Drivers

It's long time after you asked this question....

 

My E71 got the same problem. You can try the follow way

 

download

1. mdmcpq.inf  and copy it to    C:\WINDOWS\INF
2. usbser.sys and copy it to      C:\WINDOWS\SYSTEM32\DRIVERS\

Please use plain text.
Registered Member
lepidoptera
Posts: 1

Re: CDC Comms Interface Drivers

Hey eliminator. Thanks . I worked great on my E62. Been knocking my head all over for a couple of days. And then your solution.

thanks

 

Please use plain text.
New Member
vynbos
Posts: 3

Re: CDC Comms Interface Drivers

[ Edited ]

I found a solution that worked for me without my needing to re-install the cable driver (this is on Windows 7, but might work with Vista). The cable driver that PC Suite uses is located at:                                                C:\ProgramData\Installations\{D0D14551-3A2D-433B-861F-F4DCE5422759}\Packages\CCD\Setup\Nokia_Connectivity_Cable_Driver.msi                                      (your long string of letters will be different. )            For some reason, I don't know why, PC Suite suddenly started looking for the cable driver under a second, different string of letters. It couldn't find it, and so kicked up the 'no available connection type' error. I COPIED rather than moved the "CCD" folder which holds the cable driver to this new string. (the reason i copied it was just in case PC suite starts looking under the old string again.) When i re-started PC suite it prompted to set up the phone and this time it worked with out a "no available connection type" error message.

Please use plain text.
Registered Member
ejder123
Posts: 1

Re: CDC Comms Interface Drivers


eliminator wrote:
I have an E90 Communicator, which I use to connect to the internet on my PC via a USB cable. It all worked fine with XP, but after upgrading to Vista, I am unable to connect. The latest version of PC suite says that there is no modem found, and Vista keeps asking for CDC Comms Interface drivers, which I cannot locate. I have tried everything I know - using the version of PC suite that worked with XP, uninstalling and reinstalling... etc.

The handset is seen by XP, I can do everything except connect to the net.

Please can someone help me before I have a mini-meltdown?

 

Please use plain text.
Registered Member
vahsi
Posts: 1

Re: CDC Comms Interface Drivers

süper
Please use plain text.
Contributor
pavinan
Posts: 7

Re: CDC Comms Interface Drivers

install ovi suite and connectivity in windows xp sp2 computer,then goto c:\windows\ini and copy all the files except folders into a pen drive and paste them from pendrive to computer to your computer c:\windows\ini
warning:donot copy folders.if the driver installer asks anything search the c: drive using search engine and browse to them
Please use plain text.
Registered Member
Alaa_alaa_king
Posts: 1

Re: CDC Comms Interface Drivers

Grezur.you made my day
Thank you very much
Please use plain text.
Registered Member
makedonija
Posts: 1

Re: CDC Comms Interface Drivers


eliminator wrote:
I have an E90 Communicator, which I use to connect to the internet on my PC via a USB cable. It all worked fine with XP, but after upgrading to Vista, I am unable to connect. The latest version of PC suite says that there is no modem found, and Vista keeps asking for CDC Comms Interface drivers, which I cannot locate. I have tried everything I know - using the version of PC suite that worked with XP, uninstalling and reinstalling... etc.

The handset is seen by XP, I can do everything except connect to the net.

Please can someone help me before I have a mini-meltdown?

 

Please use plain text.