Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: N8 fault with WPA2 WiFi connections - BUG Foun...

Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

 


gtallan wrote:

I'm seeing the same problem too - connecting to a WPA2-PEAP-EAP network,my N8 hangs or sometimes rboots shortly after connecting. This is using PR 1.2 software.

 


 

BTW I don't think it has anything to do with EAP or particular cipher in use. Maybe more general. I managed to connect to the same WPA2 network in two different ways: first with EAP-PEAP with EAP-MSCHAPv2, and also with EAP-TTLS with MSCHAPv2. And also tried selectively enabling or disabling the various sets of ciphers. In each case whenever I was able to connect, the phone would freeze within a minute (and reboot shortly after that).

 

It does work fine with a WPA2-PSK network elsewhere.

 

I wonder if there is any way to disable the different wireless modes, eg if this is something to do with 802.11g vs n?

 

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Another followup.

 

Restoring factory settings (Menu > Settings > Phone > Phone management > Factory settings > Restore) didn't work.

 

Next tried a hard reset (*#7370#). Of course lost all settings and apps which is a pain even after only 2 days with the phone, but if it's that or giving up and returning it... So far this does seem to have fixed it, but goodness knows what was causing the issue. At present it's in the "factory" PR1.2 state, with the problematic WPA2-EAP network added back, and seems to be working ok - it's lasted for 5 minutes anyway, and was only lasting a  few seconds before...

 

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

 


gtallan wrote:Next tried a hard reset (*#7370#). Of course lost all settings and apps which is a pain even after only 2 days with the phone, but if it's that or giving up and returning it... So far this does seem to have fixed it, but goodness knows what was causing the issue. At present it's in the "factory" PR1.2 state, with the problematic WPA2-EAP network added back, and seems to be working ok - it's lasted for 5 minutes anyway, and was only lasting a  few seconds before...

 


 

Still not fully fixed. it hung again as soon as I re-added my Mail for Exchange account (to sync calendar and contacts from google account). That hung twice so I deleted the MfE account again. Then added my regular imap mail account which did sync without issue.

 

But don't know if these can really be related, I don't see why the hangs before I did the hard reset should be related to MfE (even though it was configured and active, so it could be related, but I think set to use a different network destination/access point). Seems more like general bugginess, to be honest...

Please use plain text.
Registered Member
johnson1970
Posts: 2

Re: N8 fault with WPA2 WiFi connections - BUG Found?

i had same problem with n8 WLAN  not onnected but icon showing connected not open any page  when open  ! Connection Failed  Unable to connect please review your network settings .comeing like tell me sloution for me

Please use plain text.
Registered Member
johnson1970
Posts: 2

Re: N8 fault with WPA2 WiFi connections - BUG Found?

every think showing connected but not open page connection manager showing status Conn (inactive) what is solution for active pl tell me
Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

 


gtallan wrote:

 

Still not fully fixed. it hung again as soon as I re-added my Mail for Exchange account (to sync calendar and contacts from google account). That hung twice so I deleted the MfE account again. Then added my regular imap mail account which did sync without issue.

 


 

As I feared, this is NOT fixed. Coming to work today, the N8 froze and rebooted within 2 minutes of connecting to the wireless network. MfE is not involved as it's not configured, this was when opening regular imap email. This makes the N8 useless for me, and I can't think of anything else useful to try. I'll give it a few more days and see if Nokia Care respond with anything useful, otherwise will have to return it.

 

 

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

 


hadimassa wrote:

Turn off WPA2 only mode.


 

If this is meant to help with the hang when connected to WPA2 Enterprise networks, I can confirm that is does NOT help. My phone still hangs within 1 minutes of use.

 

Would be nice to see some actual Nokia response here.

 

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

I spent some time with our network engineers this afternoon seeing if we can debug the problem. The wireless network is based on Trapeze (now Juniper) equipment. Over in their test lab, with a wireless controller running the most recent Trapeze software, the N8 lasted a lot longer, but eventually froze in the same way. There's also a lot less wireless traffic in general over there, so we tend to think it's more related to that than the controller.

 

I'm happy to continue working on debugging this if anyone from Nokia might work with me (forlorn hope?).

 

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

 


gtallan wrote:

BTW I don't think it has anything to do with EAP or particular cipher in use. Maybe more general. I managed to connect to the same WPA2 network in two different ways: first with EAP-PEAP with EAP-MSCHAPv2, and also with EAP-TTLS with MSCHAPv2. And also tried selectively enabling or disabling the various sets of ciphers. In each case whenever I was able to connect, the phone would freeze within a minute (and reboot shortly after that).

 


 

I'm questioning what I wrote here now, I think it doesn't make sense. I was enabling/disabling the various ciphers available under EAP, but of course these only affect the handshake. For data transfer it's still either TKIP or EAP, and I think for the network where I get the crashes, it is fixed to EAP (WPA2).

 

I need to check whether my wlan at home is using TKIP or EAP, I would have thought the latter but don't remember for sure. Since the phone always authenticates a connection successfully but hangs later during data transfer, I don't really see why it should make a difference whether the network is PSK or EAP - seems more likely related to the WPA vs WPA2 encryption.

 

Although there are so many other things it could be related to, eg wlan control traffic, roaming between different (physical) access points, etc.

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Home network is using AES, so it's not directly related to that, so either related to EAP or possibly wireless n (work) vs g (home).

 

Now received a replacement N8 to the first one. I left it in completely out-of-the box configuration, firmware PR1.0 (the last one I had updated immediately to PR1.2), I haven't even put a SIM or memory card in.

 

Brought it to work, configured the wireless network, opened a simple web page, waited a little while. It hung totally within 3 minutes.

 

I think there's no doubt this is a software bug within Symbian, and not a hardware issue.

 

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

I spent some time talking to Nokia Customer Service about this. They took the case details and said they would talk to the R&D department. Called me back a week later and said, yes this is a known issue which other people are also experiencing, and should be fixed in the next firmware update ("possibly around 2nd-3rd week of May").

 

Please use plain text.
Registered Member
Posts: 1

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Aahh yeah that fixed it. I have been messing with this thing all day with no success. All other devices connect fine to WPA2 wireless except new $380 N8. I was close in frustration to returning it. You saved it. Thanks. Working great now after disabling power saving mode.
Please use plain text.
Contributor
bekstar66
Posts: 8

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Someone said turn off WPA2 only buttom.

 

How do you do that, please?

Please use plain text.
Contributor
bekstar66
Posts: 8

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Not to worry, as I realise you are talking about the router, which would not help when trying to use at other addresses or venues.

Please use plain text.
Advisor
rvandi
Posts: 21

Re: N8 fault with WPA2 WiFi connections - BUG Found?

f00k, I am experiencing the same problem, does anyone know if this has been fixed in symbian anna?

Please use plain text.
Advisor
gtallan
Posts: 24

Re: N8 fault with WPA2 WiFi connections - BUG Found?

customer service told me it would be fixed in the next firmware update (ie anna). I wish I knew for sure... can't believe it until i see it myself.
Please use plain text.
New Member
dtserkanozkan
Posts: 5

Re: N8 fault with WPA2 WiFi connections - BUG Found?

I bought my n8 8 days ago. First 3 days of it, connected to wlan at my home with success. But after then, it began to say 'connection failed, WLAN not found' although my computer was able to connect to the same WLAN. First I changed the security type from WEP to WPA. But the problem remained unchanged. Then I selected no security with MAC address filtering and it seemed worked for a few days. Yesterday it couldn't connect again and I realized that if I come home from the work and go to market for a while, after the market return it can't connect. Going to market, shooping and returning took about 30 mins. So if the cellphone looses the signal for a long time and sees it again, it can't connect (moreover, it mustn't connect to another WLAN after loosing the home WLAN signal meanwhile). Problem is occuring in this way. To connect again, I deleted the remembered WLAN name from the settings and reset the WLAN router. This is my solution. So if you have the same problem as mine, do not loose the signal of your WLAN.

Please use plain text.
Contributor
haribabu_vk
Posts: 7

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Well here is my 2 cents...

 

Had this issue of my router getting disconnected from net once I get a connection going on from my N8. This had me bugged so much that I started downloading stuff on PC and transferring to N8.

 

It never occured to me to google this prob of mine until today. After reading all the 3 pages tried the first easier option to turning off power saver on wifi and guess what, it is freaking working.

 

BTW am on a Dlink router with WPA2-PSK AES.

 

Hope this helps someone

Please use plain text.
New Member
dtserkanozkan
Posts: 5

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Hello. I have bought this router:

http://www.tp-link.com/products/productDetails.asp?pmodel=TD-W8961ND

For 1 week, I have never had a connection problem. Security is WPA (not WPA2) and power saver is on. Before this router I was using USROBOTICS. I don't know the reason but I am happy now with my n8.

 

In addition, there have been no problem like this in my work WIFI system. There are WPA on the and brand name is Airties. I hope this will get fixed after the Anna update in August.

Please use plain text.
Registered Member
RingDing
Posts: 1

Re: N8 fault with WPA2 WiFi connections - BUG Found?

Own the Dlink router dir 655. Until today had the same problems with my N8.

The first connection was always ok, but once disconnected en trying to get on the internet again ;no way.(invalid servername thing)

Only rebooting the router did the job.

After turning off the powersaver on my N8 all problems with WiFi are gone.

Thanks a lot to the forum community, why can't Nokia provide us with this kind of information ?:smileymad:

Please use plain text.