Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Nokia 5800 Xpress Music Wi-Fi Problem

Contributor
Posts: 9

Nokia 5800 Xpress Music Wi-Fi Problem

Hi,

 

I have set up my wi-fi connection to my router at home, put in the wep key and everything is fine and dandy.  When I go to the connection and select Start Web Browsing, I can use the internet. 

 

I have changed the internet icon homepage to google rather than the 3 mobile one and I can connect via my router.  However, if I try to connect any application through the router (such as any of the games that came preloaded) it does not connect to the internet!  It's obviously a working connection but there is a setting somewhere that I am clearly missing. 

 

My Wi-Fi settings are:

 

Data Bearer - Wireless LAN

Network Status - Public

WLAN Network mode - Infrastructure

WLAN security mode - WEP

Homeapge - none

Use access point - automatically

 

Security settings:

 

Key in use - #1

Authentication type - Open

 

Please let me know if there is anything else you need to know.

Please use plain text.
Contributor
Posts: 9

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Still getting this problem!!  I've even downloaded Opera Mini.  This works through my WAP connection.

 

My Internet Explorer works fine when I connect to my LAN but when I open Opera Mini and select the LAN as the connection it does not load!  It says there is not internet connection.  Then if I click on the usual Internet Icon and select LAN it connects fine!  Grrr this is driving me insane.

 

HELP.

Please use plain text.
Sage
Posts: 134

Re: Nokia 5800 Xpress Music Wi-Fi Problem


CraigMcKee wrote:

Still getting this problem!!  I've even downloaded Opera Mini.  This works through my WAP connection.

 

My Internet Explorer works fine when I connect to my LAN but when I open Opera Mini and select the LAN as the connection it does not load!  It says there is not internet connection.  Then if I click on the usual Internet Icon and select LAN it connects fine!  Grrr this is driving me insane.

 

HELP.


 

Try checking priority order of your access points within the "Internet" destination. There's also a "Default connection" setting on the Destinations menu that might be set to something else than Always Ask or Internet. In case you have created your WLAN access point to some other destination than Internet and Internet Destination is set as Default Connection it might cause some applications to fail connecting. You might also want to check if Opera Mini has been set to use some specific access point (like e..g your cellular packet data connection).

 

For more detailed instructions on how to configure previously mentioned settings please see following thread/post: /discussions/board/message?board.id=connectivity&message.id=25974#M25974

Please use plain text.
Contributor
Posts: 9

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Thank you I've followed your instructions from you link and still no joy.

 

The priorities are set correctly.  I went into installed apps and settings and one application was set to 'none' which I gather means it can ask.  I changed this to my router at home, that I can connect to via the phone for the internet, but it is still not loading.

 

For some reason this java application will not use a wifi connection?! I did phone the help desk and spoke to two people. 

 

The first who was unbelievably useless ended up getting cut off.  The second didn't know anything about the phone and said he would call me back the next day.  Suprise, suprise he didn't.  I'm getting really annoyed with Nokia!!! Any help from you knowledgable folks would be greatly appreciated.

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Use access point - automatically??? Set it to manually.
‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Contributor
Posts: 9

Re: Nokia 5800 Xpress Music Wi-Fi Problem

If you look HADIMASSA I have said that I have done that and it did not work.

 

If it makes any difference it would appear that the applications that don't work using Wi-Fi are the applications on the SIM card although I'm not sure why that would make a difference.  Although, that seems to be the difference.  Ones of the phones work and the ones on the SIM card don't.

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Well CRAIGMCKEE, on your first post, you write "Use access point - automatically". With SIM card I assume you mean Memorycard. You better install all your apps in the phone's memory to avoid conflicts.
‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Contributor
Posts: 9

Re: Nokia 5800 Xpress Music Wi-Fi Problem

No, I mean SIM card.  I didn't install these applications, they came with the phone.  I have to assume SIM card rather than memory because I put the memory card in from my old phone and I didn't have these applications they were already there and when I'm in installed apps it shows a picture of a card next to them, suggesting they are not saved on the phone. 

 

On my last post I said that I had tried setting it explictly to my router at home, not automatic. 

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Xpress Music Wi-Fi Problem

I've never seen that before. The SIM card usually contains some services from you SP, but the SIM card is only 128 KB. Some apps are preinstalled in the firmware and if you install e.g. Opera you will be asked to either install in the phone's memory or on a SD card. If you start Opera, it should ask you what kind of connection you want. You can delete all access points, even data packet connections, except your WLAN, then there are no options.
‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Contributor
Posts: 9

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Perhaps that is true, I know they're definately not on the memory card.  You are right when I installed Opera it asked me where I wanted to put it and in that instance I chose the phone because that was recommended and being Opera Mini it is very very small.  That works with the WLAN connection though, so it still would seem the WLAN only connects to the internet via applications stored on the phone and it wont connect for those on the memory card / firmware which seems strange to me but this is the problem I am having.  I appreciate your input HADIMASSA.   Hopefully I'll be able to sort this out.
Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Reinstall the apps you need in the phone's memory and if you remove the SD card, use the red button and choose from the menu "remove memorycard". There are some known issues with the 16GB SD card so you better use the 8GB card. Format the card in the phone, not on a PC. 
‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Contributor
Posts: 9

Re: Nokia 5800 Xpress Music Wi-Fi Problem

Some were already installed when I got the phone so not sure what to do with them.
Please use plain text.
Registered Member
Posts: 1

Re: Nokia 5800 Xpress Music Wi-Fi Problem

CraigMcKee, it was a while since you last post...hope that you had got it working...if not...here is my experience after I got my 5800 (for about 2 months):

Some application just don't work with Wifi at all. Eg., Nokia Mail. It does not ask...just use 3G or GPRS directly.

Some application goes to check on your access point etc. (then it will work with the method suggested earlier in the forum)

Some application is so stupid (sorry about the word)...then, you'll need to go to "Setting", then "application management", then "installed applicatoin" to show you the list of installed applications. Then, click on the application and select options...for some application, you have a choice to select what access point to use - specific to the application. For some application, this option just does not exist and you are of no luck.

 

Sorry, I use a Chinese language phone so the title of the options like "setting" etc. are only approximate translation but I hope you get the idea.

 

Ray

Please use plain text.
Registered Member
Posts: 1

Re: Nokia 5800 Xpress Music Wi-Fi Problem

saataja....Thanks so much for this link!!!  I was getting very frustrated with these same connection problems and the info in this link solved them perfectly. I really appreciate you taking the time to help.
Please use plain text.
Sage
Posts: 134

Re: Nokia 5800 Xpress Music Wi-Fi Problem

@Tokk:

Your welcome, I'm glad you found it useful.

 

@ray_5800_forum:

 

Like explained in a another thread that was linked above, connectivity settings for Java based applications can typically be configured via Application Manager -> Installed Applications -> Options where a specific Access Point can be selected for the particular application or you can select "None" which should cause a Access Point selection prompt each time this application attempts to connect.

 

According to my understanding Java based applications don't seem to support "Destination" concept (Access Point grouping and priorization) which is included in S60 3rd Edition FP2 and S60 5th Edition phones. There's also still many S60 native non-Java applications (built-in and 3rd party apps) which might not be fully utilizing the Destination concept.

 

I don't have experience on 5800XM email usage but at least on E72 there seems to be a way to configure which Access Point email uses by default. Please note that situation might be different for Nokia Email service since I have only used independent IMAP email accounts with the E72 built-in Email client, without using the Nokia Email service.

 

What I have seen on E72 is that each email account that has been added to the Email client has their individual connectivity settings.

 

E.g. Gmail and OVI Mail (IMAP accounts) have separate individual default Access Point settings buried deep in to the Mailbox and/or  Account settings. So for example OVI Mail email account can be configured by going to Email application -> Settings -> OVI mail ->Account Settings -> Account Information -> Access Point -> where a fixed WLAN or packet data IAP can be chosen or "None" option can be used if "prompting" is preferred for connecting to this email account.

 

In my case default connectity behaviour of Gmail account is configured via: Email application -> Settings -> Gmail -> Mailbox settings -> Advanced mailbox settings -> Incoming and Outgoing email settings are separataly configurable -> select "Access Point in use" -> where options are "User defined" and "Ask Always".

 

Like said, this may or may not apply in your case (5800 and Nokia Email service), but hopefully it will provide some tips how to find the place where email account's default connectivity settings might be available.

Please use plain text.
Registered Member
albidragusha
Posts: 1

Re: Nokia 5800 Xpress Music Wi-Fi Problem

I Remove My WLAN And Now I Wanna IT Back But I Cant Find It When I Find At Search It Says To Me System Error And When I Try It To Internet It Says 
Select Connection :
(no data) 
Can You Please Help Me I Need WLAN So Much 

Please use plain text.