Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: E72 - Wireless Problem - "invalid server name"

Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

Yes, well I found that OpenDNS demanded a registration etc with much form-filling (I've used it before, and didn't have that). So I just manually entered a DNS server address (from my router) of 192.168.1.254, leaving the second address to "Auto" or "home" (I forget which) and that worked. I haven't tried that with other links, just my home network.

 

However, it is a common (intangible) problem - see http://forum.dailymobile.se/indexing?topic=16727.. And there is one post which describes it as a random occurrence on his E72 (http://nokiae72bugs.wordpress.com/ - December 22 posting)

 

But generally, it appears that the error is an Invalid DNS address, which seems to get corrupted over time. A reboot should clear it - or reduce the incidence.

 

However, there are as many different solutions as people hitting the problem, so I'm not at all convinced that there is a single root cause (but there must be)

Please use plain text.
Registered Member
iqpersonal
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

:smileyhappy:

 

Thank you verymuch

Please use plain text.
New Member
quigonbond
Posts: 2

Re: E72 - Wireless Problem - "invalid server name"

Hi, I've just bought the e72 set and is encountering the same problem with internet server name. I tried all the suggested solutions on this forum but still can't connect to the internet.

 

Just to clarify, ozidug, when you mentioned in your first paragraph that the second address is set to auto, it means "0.0.0.0" right?

 

In your third paragraph, you mentioned rebooting - that's switching off my e72 and switching it on again?

 

Thanks if anyone has any further thoughts on this.

Please use plain text.
Registered Member
vadfrol
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

In my opinion nothing to do with dns.

I just helped upgrade software on wifi access points. I think  E72 have some problems with encryption and public key to some points has only a "AES only" - try different variations. Another big help swich off energy safe mode of WLAN.

Please use plain text.
New Member
quigonbond
Posts: 2

Re: E72 - Wireless Problem - "invalid server name"

HI vadfrol, thanks for your comment. Could you direct me to the link where you upgraded software on wifi access points?

 

I also can't seem to find the energy safe mode on my E72.

 

With this glitch in E72 software, I'm wondering why there's no specific writeup from Nokia on this issue. In my mind, no ready connection to wifi seems like breach of warranty. I had no difficulty at all when I was last using E65.

 

Anyway, thanks a lot.

Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

1. Yes, setting the IP address to 0.0.0.0 was taken as "Auto" as soon as I entered it.

 

2. By 're-booting' I mean to take the battery out. It seems to need that daily. Luckily, it's easy.

 

Apologies for the late reply - I've just rerturned from Sicily, having been stuck there by the air traffic control embargo. I'm old enough to qualify for Saga holidays, so it was an extra 8 days with free food and drink.

 

Nonetheless, glad to be back!

Please use plain text.
New Member
pyaarey
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

Even though people have reported it solved, I am writing my experience here. I got the phone yesterday and was configuring the WLAN settings. It took me almost 3-4 hours to configure. It is not easy. I am thankful to the forum which gave me pointers to look for various options and configuration of Phone as well as wireless router that I am using.

I have Linksys Wireless G BroadBand Router Model #: WRT54G. Firmware Version:v8.00.5

Important Setting I had set earlier was in: Status -> Local Network, where I had defined Start IP Address: 192.168.1.100 and End IP Address: 192.168.1.104. It means I am allowing only 5 machines to connect to my wireless network ranging from 100 to 104. This range is defined in the section Setup -> Basic Setup. DHCP Server: Enabled, Starting IP Address: 192.168.1.100, Maximum Number of DHCP Users: 5 (this I have configured for my wireless domain).

Section: Wireless -> Basic Wireless Settings Configurations

1. Wireless Network Mode: Mixed.

2. Wireless Network Name (SSID): MyWireless

3. Wireless Channel: 6-2.437GHz.

4. Wireless SSID Broadcast: Enable.

 

Section: Wireless -> Wireless Security

1. Security Mode: WPA Personal

2. WPA Algorithm: TKIP

3. WPA Shared Key: Wireless Connecting Password (alphanumeric) <your password>

4. Group Key Renewel: numeric numbers (length 5) <your security numbers>

 

Rest all settings are the default one.

Now the changes that I have made in the phone are listed here:

1. Menu -> Ctrl Panel -> Settings -> Connection -> Destinations

2. Click Access Point. Pops up a msg to add a new access point. Click OK.

3. It will list available access points: (a) Wireless LAN (7 networks avail.) in my case (b) Packet Data (available). Click option (a) Wireless LAN.

4. It will list down all the available WLAN. Scroll to the one that belongs to you, and click to select it.

5. It will ask for Pre-Shared key for WLAN. Input your WPA Shared Key here. Once done click Ok.

6. Another Pop-up will ask for "Select Destination:". Click to Select 'Internet'. A popup message will appear to confirm that a new 'internet' access point is added. and automatically return to the main page.

7. Click 'Internet' from Network Destination Screen. (2 access point).

8. Click to select the one that is your wireless SSID Name.

9. In this screen there are lots of options... giving all the values:

a. Connection Name: Your wireless SSID name. You can change it to some meaningful to appear in your screen. For example, My home LAN or something like that. Change is optional though.

b. Data bearer: Wireless LAN

c. WLAN network name: Your wireless SSID. No need to change it.

d. Network Status: Public

e. WLAN network mode: Infrastructure.

f. WLAN security mode: WPA/WPA2

g. WLAN Security Settings: Click it to get into another screen.

g1. WPA/WPA2: Pre-shared Key.

g2. Password already exist in here. If not, input it.

g3. WPA2 only mode: Off. Click Back to go back to step g.

h. Homepage: none. You can define a home page here, but not necessary. I set it to http://mobile.msn.com/.

i. Use access point: Automatically.

DO NOT click any other button, as you are NOT done yet. Now Click 'Options', and click 'Advance Settings'. There are various options in there:

1. IPv4 settings

2. IPv6 settings

3. Proxy Server Address

4. Proxy Port number

To get the correct values for IP, you need to start your computer, go to command prompt and then type ipconfig /all. Lots of options listed down in the window. Look for the specific one that is related to your wireless LAN. Look for header something like "Wireless LAN adapter Wireless Network Connection:". In this heading, you will be using following entries for your phone:

1. Subnet Mask

2. Default Gateway

3. DNS Servers (1st and 2nd one for Primary and Secondary).

 

Click to select option 1. IPv4 settings.

1. Phone IP Address: 192.168.1.102 --> this is what I gave. Yours could be different and within range of Start and End IP Address in the wireless router settings, if defined.

2. Subnet Mask equal to the one defined in command prompt.

3. Default  Gateway as defined in the command prompt.

4. DNS addresses: Click it to input Primary and then secondary IP address as defined in the command prompt.

Once you are done with IPv4 settings, click 'Back'. You are done with your settings.

Go to home screen by clicking 'End' button on the phone.

 

On the home screen, if wireless is listed there, you can see your wireless name saying it is found. Scroll to it and then click it, and then click 'Start web browsing'. If you have defined the home page, it will connect to the home page automatically.

 

The important point that I was missing was that in my wireless configuration, I had defined maximum number of DHCP users and valid IP address range. I was giving invalid IP address and phone was giving me 'Invalid Server Name' error again and again. Once I set it up correctly, here I go. All set to use the wireless.

 

Hope these steps help somebody. Thanks!!

 

Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

That's a finely detailed post; I hope it helps other people.

 

It's unfortunate that the E72 needs this extra information (I'm thinking specifically of DNS address, in my case), because it prevents us from using public wi-fi connections, where I spend many of my bowsing minutes. I can't quite ask the manager of a Starbucks to show me the results of an "ipconfig /all" command :-)

 

Still, thanks for the details. It does mean that a pre-defined WiFi connection should be OK.

 

 

Please use plain text.
Advisor
MiC2005
Posts: 16

Re: E72 - Wireless Problem - "invalid server name"

[ Edited ]

Hi guys,

 

My experiment....

I have 2 routers, one at home and one at work. Both are the same: Thomson Speedtouch 780 (sw 7.4.5.1) Provider KPN (Dutch).

I have my E72-1 for 3 day's now and i tested almost everything. My WiFi mode was wpa/psk but i get a invalid server name when i wanted to connect. On internet i wrote that this is a bug so i went to experiment. I downgrade my Wifi security to WEP. Still same error, not working. After that i wrote that it also has something to do with dhcp (E72) So i went to mij Wifi connection on E72 and i modified the IP settings to a fixed IP address, Gateway an DNS servers. After that it worked. I can connect :smileyhappy:

But i don't want to use WEP so I upgrade my security at router back to wpa but after that my E72 doesn't work :-( It's back to WEP now.

 

I was happy untill i went to work today. Make a (wpa) connection to try first... Invalid server name. Yes that's correct because it's stil on wpa ;-) So i downgrade router Wifi security also to WEP and modified this Wifi connection (E72) for fixed IP settings (same as home). Reboot router and E72 so we start with a clean test ;-)

Damm "Invalid server name". I can't find out what the problem is but i can say that it's not the encryption level, key, dhcp etc. ect. I didn't check other wifi routers but i wrote that you guys not all have Alcatel? I can't modify on my router because my provider blocks a big part of the router. I can set security level and password but no advanced settings.

I am going to call Nokia and Alcatel to find a solution for it.

 

MiC

 

Update: My Nokia E51 is working fine on WPA and WEP so i think it's not the router.

Please use plain text.
Contributor
Ph0neman
Posts: 8

Re: E72 - Wireless Problem - "invalid server name"

This seems to be a real issue for quite a few......

 

Lets go back to basics

 

1. Delete existing Wireless AP

 

2. Use WLAN Wizard

 

Select Menu > Ctrl. panel > Connectivity > WLAN wiz.

The WLAN wizard helps you to connect to a wireless LAN (WLAN) and manage your WLAN connections.

If the search finds WLANs, to create an internet access point (IAP) for a connection and start the web browser using this IAP, select the connection and Start web browsing.

If you select a secured WLAN, you are asked to enter the relevant password. To connect to a hidden network, you must enter the correct network name (service set identifier, SSID).

 

If this works and you are connected to your WLAN here is how to check once and for all if it's a DNS Issue, using raw IP

 

1. Open up your browser and in options click go to web address.

 

2. Delete http://www. and type in a known IP Address e.g. 66.102.9.103 (google.co.uk.)

 

if you get the google page come up and you couldn't before it is a DNS issue....100%.

 

 

 

 

** Please hit the star if you found this post useful **

Nok E71, Nok E90, Nok 5800, Nok E66, Nok E63, HTC Touch 2 etc etc.....
Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

There's no doubt in my mind that it is indeed a problem with DNS, but I think it's a software problem in the E72-1. Googling "Invalid Server Name" erveals problems across many later model Symbian phones (E72, N75, N95) and I think they probably use the same telephony software.

For my home network, setting the right DNS address to 192.688.1.254 had fixed the problem. For external WiFi places, it's still there, but taking the battery out and restarting the phone did help, so I reckon it's a corruption during use. One post I saw (N97, though) said that the WEP key was changed during the phone's normal use, and that sounds like the sort of error that could be causing it.

I have no doubt that t it's caused by a code error in the telephony software. Removing the battery and restartiung the phone is about the best suggestion so far. Nokia are silent on the issue, as far as I can tell.

Please use plain text.
Advisor
MiC2005
Posts: 16

Re: E72 - Wireless Problem - "invalid server name"

[ Edited ]

Hi guy's

 

Update: Today i called to KPN (my provider) to inform them about the connection problem. They know the problem but they don't want to fix it because they don't serve external devices...The guy had several questions and complains received :smileysad:

 

I know exact how to setup wifi on Nokia so that's not the problem ;-)

It can be a E72 or other symbian problem because my E51 is working oke on the router?

 

So I did some long tests yesterday with 4 different routers and AP's. The Alcatel ST780 (KPN) is the only router that's not working. When i walk to the other AP (upstairs) the E72 connect perfect and i have full speed Internet...

Sometimes it's work very short just like  ozidug say but after 20 a 30 seconds the connection breaks down and i get the error again. Turning E72 off and on works here.

I have test DHCP, static IP, Gateway and DNS but it all don't work stable like other routers. 4 out of 5 test AP's work well !? So is it in my E72? It's a combination of Alcatel Speedtouch 780 settings and Symbian i think. Also i tested every security setting from WEP to WPA(2), HEX, DEC, 64 and 128b codes but non of it worked stable. I think it's deeper in the wifi settings like QOS on Wifi but i can't test it because i can't access to that router part. It's blocked by my provider, they do external config.

 

So what i did now (at home): I connected via CAT5 cable a Alcatel TG185n Wireless N Repeater (mode: Ethernet to wifi)  It work as new Access Point but you can also try a other brand. I placed it on the first level in my house for good cover and switched off the original Alcatel wifi. I moved my Wifi network on other hardware. It's working now stable. For me it's just a workaround but i have send my provider a letter to inform them and that i want a good solution for it. Otherwise i switch provider :smileymad:

 

MiC

Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

@MiC2005: The fact that your E51 works fine  still suggests a problem with the E72 software, rather than your ISP. But of course there are two parties involved - your phone and the ISP's router, so either (or both) could be wrong. And since it only goes wrong with the Alcatel hardware, that suggests an incompatibiity between the two devices.

 

Now, THAT's going to make it hard for either party to investigate! When I get home, I'll have a look at the hardware I've got running. It's a modem provided by BT, with an anonymous (Chinese) LAN extender. No Alcatel there, but it might explain the different experiences we're all having.

 

Please use plain text.
Registered Member
zoranstalevski
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

I am having the same problem on Nokia X6 (the 16GB version) and a Speedtouch wireless router (THOMSON ST780). My Internet provider is T-Home in Macedonia.

 

I tried every one of the proposed solutions above: from changing the Wi-Fi's security key to manually setting the IP address, subnet mask, gateway and DNS servers (both router's and Open DNS pair). Nothing works!

 

I read in another thread about disabling the QoS on the router, but unfortunately I don't have enough access rights as power user. I suppose that's available to admins only.

 

I would appreciate any other idea that might solve this problem. Thanks!

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: E72 - Wireless Problem - "invalid server name"

If  it's your own router you should be able to log in as admin. Reset the modem first and enable DHCP. Try the wireless connection first without password (WPA/WEP).

‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
New Member
overrun
Posts: 4

Re: E72 - Wireless Problem - "invalid server name"

Hi! I have e52, and i had no problems with firmware 21.013. I could connect to any wlan network. But i updated my firmware to 34.001 i think and now i have the same problem (would like to downgrade now). Configuring the dns server in the phone helps, but the same dns server is bad at my office or at any hotspot. Its annoying. Anyway it's firmware problem.

Please use plain text.
Advisor
MiC2005
Posts: 16

Re: E72 - Wireless Problem - "invalid server name"

Hi guys,

 

Yesterday i have received 2 new routers for home and work location.

The old were ST780 and the new are TG797. I have replaced the routers and Wifi is working fine now. The problem is that my provider is not going to release new firmware for the ST780. It's to old they say. They have now new hardware versions like TG797. It's a newer model with newer firmware.

 

I must say that i informed the CEO (via a internal connection).

First line support say they don't support 3th party peripherals and thats where it ended :smileysad:

After infomed the CEO i get a responce ;-) "We are going to fix it for you sir".

Please find a way to inform the wright guy and hope they give you a hardware swap.

 

Good luck!

 

MiC

Please use plain text.
New Member
dorothy520
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

I have tried all the possible solutions suggested here, but yet i still have the "invalid server"!! :smileysad: I have the urge to return my phone, and yet i love it much. Plz help!!

 

I am using a 3rd party open wireless network too. My laptop connected to it just fine, very fast internet connection. My E72 sometimes work and most of the time shown invalid server name. I really have no idea why it is only connected when "it feels like".

Appreciate if the E72 expert could help me to solve this problem.

Please use plain text.
New Member
overrun
Posts: 4

Re: E72 - Wireless Problem - "invalid server name"

I switched on in the router "Wi-Fi Protected Setup" (a standard for easy and secure establishment of a wireless home network -wikipedia)option and it solved my problem. All i have to do now is enter the Preshared Key and it works. I dunno does other routers have this option mine is a belkin product.

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: E72 - Wireless Problem - "invalid server name"

 


dorothy520 wrote:

I have tried all the possible solutions suggested here, but yet i still have the "invalid server"!! :smileysad: I have the urge to return my phone, and yet i love it much. Plz help!!

 

I am using a 3rd party open wireless network too. My laptop connected to it just fine, very fast internet connection. My E72 sometimes work and most of the time shown invalid server name. I really have no idea why it is only connected when "it feels like".

Appreciate if the E72 expert could help me to solve this problem.


First reset the E72 to factory default. Dial *#7780# 12345 restore factory settings, keep data. If that doesn't work reformat. Dial *#7370# 12345 reformat, you'll lose all data. Make a backup first and restore without the settings. Clean out your browser privacy data on a regular basis. Avoid IPv4 configuration. Use "automatic" or "DHCP". Turn off power saving in the advanced settings of WLAN.

 

‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.