Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: E72 - Wireless Problem - "invalid server name"

Registered Member
fan_okia1
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

HI,

 

I have already tried with the steps given by you, but without any success. Can u help me to fix it.

 

Mine is a corporate network. my phone MAC address is registered in the network. I've bridged both wired & wireless network. but no luck.

Please use plain text.
New Member
Stanimir
Posts: 3

Re: E72 - Wireless Problem - "invalid server name"

hi there, you seem to be experts with nokia applicationns. I'm trying to download a windows live messenger for my nokia x6, but cannot succeed. Could you tell me how i can do that for free? Please reply to zapopalvane@yahoo.com thanks very much
Please use plain text.
New Member
Stanimir
Posts: 3

Re: E72 - Wireless Problem - "invalid server name"

one more thing :my phone keeps asking me to set up an email, while i've already done that a few times. Have you heard of that bug? ?what shall i do?
Please use plain text.
New Member
mihaidenis
Posts: 2

Re: E72 - Wireless Problem - "invalid server name"

The problem with "invalid server name "on all Nokia phones is from a faulty chipset inside.

That means U cannot fix thru a software update.

That`s why Nokia is shutting up on this problem.

They know about this.

But management think like this:

Rate of return to warranty is low so why bother.

Conclusion?

If U have this issue go to warranty.

If U don`t have warranty sale it quickly.

That`s it.

Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

Yes, it had to be a hardware error - it was too flakey to be software (which is consistent, after all).

So that's it?

And yet... this morning my E72 is working fine with my BT router. Yesterday I tried it with Cisco routers and it failed every time.
Please use plain text.
Contributor
lennys_26
Posts: 9

Re: E72 - Wireless Problem - "invalid server name"

mihaidenis.

 

If the phone IS under warranty, are you saying that Nokia will do something about the issue (i.e. replace/repair the phone/chipset), or is the idea behind sending it to warranty simply to complain in hopes that they might address the issue?

 

I am curious about your claim that they are aware of a large scale chipset issue.  Is this rumour or do you have some inside information? 

 

To be honest, I am very disappointed with this 'problem' however I have really lost faith in corporate responsibility and would just as soon deal with the problem rather than pretend that anyone will listen on a large scale.

Please use plain text.
Registered Member
Ivanova
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

Dont buy new phones or new routers.

 

just do this:

 

open a command prompt

telenet to your router, log on as admin and disable qos. Then save it all.

 

write this at the command prompt:

 

telnet 10.0.0.138 <enter> (or whatever the ip is for your router)

admin <enter>

<enter> (blank password)

wireless qos config mode=disable (wait 30 secs)

saveall (write 30 secs)

 

surf all u want on ur cell.:smileytongue:

 

Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

Disabling QoS has already been suggested and found not to solve the problem.

 

And in any case, we can't modify the behaviour of the WiFi transmitters if they're not owned by us.

 

For me, it means that I can work with selected  Wireless Access Points, but it's a matter of chance - I can only try, and if it doesnt work, try somewhere else.

Please use plain text.
New Member
Sphinsxo
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

[ Edited ]

After trying some of the suggestions mentioned on this thread to no avail, I did what somebody here has suggested and it worked for me.

 

For the benefit of others having the same problem and before you go out to look for a new mobile or a new rouer :smileyvery-happy::

 

1- I didn't alter any of my Planet WR 415 router settings (left WEP 128bit security on) and all other settings as before.

 

2- Deleted the access point on the E72

 

3- Created a new access point on the E72

 

It works, at last... hey... the WIFI is one of the 2 reasons I bought the phone for in the first place :smileyhappy: the other being the 5mp camera on it.

 

Needless to say, check your router password is entered correctly, sometimes we can forget we had set a new password for some reason or other.

 

 

 

Nokia guys, please address this problem, it's not like the E72 is a $20 phone. Features should just work without all the frustration and time wasted spent getting an important feature such as WLAN to work. People buy Nokias for the quality and reliabilty not for the 5 cute letters stamped on them !:smileywink:

 

 

 

Please use plain text.
New Member
Mak25
Posts: 3

Re: E72 - Wireless Problem - "invalid server name"

I have a N8, but same issue...

I just solved it for my home WLAN..I did not put in the same information as on my laptop...

I have a public open network with browser based login... 

 

My laptop has:

ip address > 10.50.5.27

subnet mask > 255.255.255.255

default gateway > 10.50.5.1

DNS Server > 202.69.137.137

> 202.69.137.138

 

I set my Nokia N8:

ip address > 10.50.5.110

subnet mask > 255.255.255.0

default gateway > 10.50.5.1

DNS Server > 208.67.222.222

> 208.67.220.220

 

I am happy now... =)

Please use plain text.
Advisor
ozidug
Posts: 29

Re: E72 - Wireless Problem - "invalid server name"

Yes, it seems that setting the DNS server addresses allows me to work happily with the router in most cases I have tried. The trouble is that I have to set the DNS address for each Access Point manually, and it should be automatic (it's given by the DHCP handler when the phone first establishes the connection). Somehow it's being corrupted even though the DNS address is held correctly when you look at the Access Point settings - I managed to set it by just overriding the DNS setting from "automatic" to whatever the router wants. It's not a nice solution, but it seems to work. Of course, I can't set the DNS server for a strange Access Point (when I'm out using an open WiFi connection, for instance) so Nokia should really do something about this.

 

I'm sorry for those who've hit the same problem on the N8, but I'm sort of glad, too. It's their flagship phone at the moment, so maybe they'll do something about it. Maybe...

Please use plain text.
New Member
kamaradski
Posts: 4

Re: E72 - Wireless Problem - "invalid server name"

First of all:

 

I managed to convince my company to get me E72s for my team instead of the standard blackberry they normally distribute. Unfortunately this has seems to have been a bad decision.

 

 WLAN not working for all 5 phones we got. All the same invalid server name error, at both the company network, as for the home locations of the users. We have been struggling with it for a few weeks now, and the manpower resources put in now over exceed the total cost of the 5 phones. This might well be the first and last Nokias we ever bought.

 

Tried solutions:

- All possible solutions in the previous 5-page thread, several locations.

- IT department is after many tries not able to fix the issues.

- Returned and switched the hardware under warranty 

- Updated the firmware.

 

Effects:

- Sometimes it works for a while (few hours) until it fails again.

- When rebooting a router, WLAN stops working 90% of the times.

- if a network works for 1 phone, it might not work for all 5 but maybe only 75% of the phones.

 

If we cannot come up with a solution for this pretty soon, the phones will be replaced for them stupid blackberries, and even though as a life-long customer my personal preference is with the Nokia, after all these problems i'm starting to think it might be for the better, as i cannot afford to loose so much time on maintaining my phone, just to be connected to the WLAN.

 

Please someone tell me what options i have left, as this is getting a little bit rediculous, even a hardware switch is not able to solve, then what can i do ..... ?

 

KR

kamaradski

 

PS: Sorry for the rant, however i'm starting to be a tiny bit frustrated by now.

 

Please use plain text.
Registered Member
ozidug2
Posts: 2

Re: E72 - Wireless Problem - "invalid server name"

Just a quickie reply - I've got into the habit of removing the battery every morning just to reset the phone. Sometimes it's not necessary, but connectivity fails later on in the day.

I'm convinced that it's corruption of the DNS address, and setting it manually (like mak25 describes, using an OpenDNS server) helps - but it could still go wrong. The IP address doesn't need to be changed, so changing the DNS address allows connection through an open WiFi connection.

I'm also sure that the Nokia connectivity hardware/software is particularly sensitive to the Cisco Access Point hardware used in most IT establishments.

I've mentioned it to the Nokia software validation team, but couldn't raise any interest. Really, really frustrating.
Please use plain text.
Advisor
MiC2005
Posts: 16

Re: E72 - Wireless Problem - "invalid server name"

Ik want you guys know that i now have a new type router (because of a speed upgrade) and it's still working on this one: Alcatel TG789vn version 8.4.2.U (@KPN Telecom~Dutch provider) No problems anymore. With the latest Firmware on the E72.

 

MiC

Please use plain text.
New Member
kamaradski
Posts: 4

Re: E72 - Wireless Problem - "invalid server name"

ok in reply of my above rant about the 5 phones i'm happy to be able to state 3 out of 5 users have their issue resolved now.

My router had a broken dhcp, and replacing the old 3com with a linksys e3000 solved my personal problems

1 user had above dns issue

and the 3th user forgot to do his hard reset after upgrading.

Seems like this error is very generic and pops up with virtually every network problem. If there was a better network diagnose tool available (ipconfig /all would already be a big help) it would make finding the problem a lot easyer and save me a lot of frustrations. For sure better and more specific error messages would also help.

Now 2phones left to fix?this week, pretty confident i'm getting the hang of it now.

Kr
kamaradski
Please use plain text.
Registered Member
Honeyku
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

Just bought my E72 yesterday and having the problem unsolved.

Worst scenario, my Add new access point can't configure my home wireless setting at all and they are on progress forever and finally the message:

WLAN configuration failed

However my son phone Nokia X3-02 having no difficulties at all to connect my home wireless.

Any solution?

Please use plain text.
New Member
kamaradski
Posts: 4

Re: E72 - Wireless Problem - "invalid server name"

let us know what router you have and what settings it is using

kr
kamaradski
Please use plain text.
New Member
emarko
Posts: 1

Re: E72 - Wireless Problem - "invalid server name"

For me the proposal: "Deactivate energy saving mode" did help instantly!

 

Some guy proposed it somwhere here in the forums and it really helped when I encountered the "invalid server name" error on my nokia E72 right from the start. When I opened a browser the first page would load fine but the click on the next link would lead to the notorious "invalid server name" error. Setting two static DNS did help a bit - then I just had to wait some minutes to go to the next page :-(  - that was no solution tfor me.

 

To deactivate the energy saving mode you kind of have to digg in your settings - I have a german version - so here is the path in german:

Menü>>Systemstrg.>>Einstell>>Verbindung>>Wireless LAN>>Optionen>>Erweiterte Einstell.>>Ja>>Energiesparmodus>>deaktiviert (just click on it to change)

 

In English this might be something like:

Menu>>Ctrl. panel>> settings>> connection>>wireless la>>noptions>>adv. settings>>yes>>energy saving mode>>activate/deactivate (just click on it to change)

Please use plain text.
Advisor
alpha_beta
Posts: 41

Re: E72 - Wireless Problem - "invalid server name"

Please use plain text.
New Member
alnemse
Posts: 2

Re: E72 - Wireless Problem - "invalid server name"

Good Evening

How are you?

I have problem with my phone(E72), I just bye it before 2 monthes and the net wireless was working nicely suddenly stopped woeking,  when I want for example to google. com it is go but after that stop and show invalide service name. I tried many times but no use, I format my phone but also same, I did resit my wireless network but also nothing..

 

so whats the solution??? pleese pleese help me??

 

my wirless network is Network Blaster wirless, AP Router and the cover of the router written Creative router.

 

I hope to find solution for my phone. 

Please use plain text.