Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: Symbian Anna Mail for Exchange not working on ...

Registered Member
JamesOD
Posts: 1

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

I have found if I change the ActiveSync policy on the exchange server and untick Require Encryption on the phone and the storage card, then MfE works again.

 

This is hardly a solution as MfE worked with these two settings ticked prior to the upgrade.

Please use plain text.
Counsellor
esr86
Posts: 35

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

ERROR 440 SOLVED!!!

With help of Nokia, we have solved the error 440. 


Our ISA server was requiring Forms Based Authentication, which is typical for OWA, not for Activesync. In fact, all Activesync clients was being directed to OWA virtual directory.


Anybody don't know how, but until symbian Anna, all Nokia phone sync ok (iPhone and Android and pre-anna phones sync ok always) with this configuration.


We have created a separate publishing rule in ISA for ActiveSync and configure it for Basic Authentication and when we have tried with our Anna devices......WORK!!!!

 :smileyhappy:

Please use plain text.
Contributor
vivax
Posts: 6

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

Our administrator found a workaround - when he created a new mailbox he entered incorrect e-mail address, as the result after autodiscovery error Nokia allowed to enter all required fields username, password, domain, server etc. otherwise when I entered a correct e-mail address then afer autodiscovery I was not able to change any of those setting and I was getting an error that I am using client certifcate....

Please use plain text.
Registered Member
ruutar
Posts: 1

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

I have E7, What about this problem “Your account does not have permission to synchronise with current settings. Contact your administrator.”  when are you solving this issue?

MFE does not work on my phone!

Please use plain text.
Technical Expert
svi78
Posts: 427

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

Thank you for feedback.

 

Could you check the admin1_log.txt file on your device? To find the log file, select Menu > Office > File Mgr. > Phone memory > MailForExchange - folder. The log files are the text files, so you can open them yourself.

The authentication error http error code = 403 has been solved and will be included in the next Symbian Anna software update.

 

In case you want to start using the interim Email client (includes solution for http error 403) you can call or send email the Nokia Support. However, if Interim Email client is installed, it must be uninstalled before the next software update. To uninstall email client, select Menu > Settings > Application Manager > Installed appl. >  long press Email > Uninstall..

 

You can find Nokia contact info from this web site by selecting Contact Us

Please use plain text.
Advisor
Nopse_fr
Posts: 10

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

Think for this information.

 

for me, there is one question again : when will we have this update ?

Please use plain text.
Technical Expert
svi78
Posts: 427

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

Unfortunately we do not know the release date for update yet. If we in the forum team receive any information about upcoming software for any Nokia phone model, we will post it on the forum.

 

 

 

Please use plain text.
Technical Expert
svi78
Posts: 427

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

@Stones and others,

 

The authentication error http error code = 401 has been solved and will be included in the next Symbian Anna software update.

Please use plain text.
Sage
metal_might
Posts: 307

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

hi svi78 and others,

 

can you pl let us know when will

 

1. nokia messaging bug be resolved?

2. communications log bug be resolved?

 

tks.

Please use plain text.
Contributor
superbully
Posts: 6

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

hello

excuse me for me english.

i have a nokia e7-00 and have problems with mail for exchange. i have readed all post.

my scenario it´s:

in my admin_log1.txt i have the next error:

 

22/09/2011 14:22:20 HTTP error code=440
22/09/2011 14:22:20 Mail For Exchange Error 440
22/09/2011 14:22:21 HTTP error code=440
22/09/2011 14:22:21 Mail For Exchange Error 440

 

 

now, i have not solution:

1.- in my case it´s not posible turn off secure conecction in mail for echange and i can not say with IT departament to make changes in exchange server.

2.- it´s not posibble downgrade to symbian^3. in symbian^3 work perfectly !

 

someone know if in the future, the people that use mail for exchange without secure connection and based in trust cetificated could use mail for echange ??

what nokia says ?

in the future updates will be the same problem ??

it´s posible use a version of mail for exchange that work the same way that in symbian^3 ?

 

someone have any idea how make work mail for exchange in my state ?

there are any solution different to mail for exchange to sync mail ?

 

THANK YOU SO MUCH !!

 



Please use plain text.
Contributor
Posts: 6

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

There is no escape. For a while the phone remembers the OK to the reminder when prompted to sync manually but then forgets it randomly again. Keeping constantly hooked up to the mail account makes no difference. And it does not make sense for me to go and try to persuade a major company IT guys to spend their time on it when others don't seem to have a problem.

Please use plain text.
Advisor
Nopse_fr
Posts: 10

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

Thanks to Nokia Care.

 

They send to me a .sisx file. after the installation and a reboot, my Mail for Exchange works !!

My http error 403 is gone !

Please use plain text.
Contributor
superbully
Posts: 6

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

hello

you can send me sisx file to try en my nokia e7-00 ??

thank you so much !!!

Please use plain text.
Registered Member
Hape70
Posts: 4

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

Nokia care in Vienna is absolute clueless about the problem and how to solve it (well done Nokia care internally!! :smileymad: )

 

from whom did you get this file? please post the email adress

 

thx

HP

Please use plain text.
Counsellor
esr86
Posts: 35

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

@superbully:

 

The new sisx do not solve de 440 error. According to our tests, the Symbian-Anna email client needs "basic-authentication" in your ISA server when it does the first sync. After having synchronized the first time. You can use "form-based auth" or "basic-auth", the client support both.


The new beta client do the same.

Please use plain text.
Contributor
superbully
Posts: 6

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

esr86:

thanks !!! then, i can not do nothing  !! only i can use mail for exchange if change the configuration exchange server , is that so ??

 

Please use plain text.
Counsellor
esr86
Posts: 35

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

According to our tests, or Nokia solve this problem in email client or you change (in the ISA server) the method of authentication to "basic" for the FIRST sync.


We done that and now, I have my N8 synchronized with our Exchange system.

 

Note: None of our others phones (iPhone, Android, pre-Anna nokia phones, ..) need "basic auth" for the first sync.

Please use plain text.
Technical Expert
svi78
Posts: 427

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

[ Edited ]

svi78: I have changed this post more General, Please check following, if it helps:

 

http://nokia.ly/onhtc8

 

You have probably been directed to OWA after a certificate warning. This is the cause for the HTTP error code=440. The server is requiring Forms Based Authentication, which is typical for OWA. All Activesync clients are being directed to the OWA virtual directory.

 

To fix, ensure that publishing rule in ISA (if applicable) for ActiveSync is configured it for Basic Authentication. Also verify that the ActiveSync virtual directory is not configured to use Forms based authentication.

Please use plain text.
Contributor
superbully
Posts: 6

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

when try with https://<servername>/microsoft-server-activesync, 

i have the next error: HTTP/1.1 501 Not Implemented

 

if i can not make changes in the exchange server and configure Basic Authentication i can not make nothing ?? other solution, it´s posible ??

 

 

Please use plain text.
Counsellor
esr86
Posts: 35

Re: Symbian Anna Mail for Exchange not working on Exchange running security settings

[ Edited ]

Yes, you can use another phone: iPhone, Android, Nokia pre-anna, Windows Mobile, ... All works perfectly with your (and our) configuration.

Please use plain text.