Search Discussions:


Showing results for 
Search instead for 
Do you mean 
Advanced search
Welcome to our community! Here you can share advice and tips with thousands of other Microsoft mobile devices users around the world in English. Please take a moment to read our community guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others you need to sign in first. If this is your first time here, you can choose an alias to represent you. If you don't have an account yet, please register here.

Here Maps for Lumia 521

Registered Member
bluesmom
Posts: 1

Here Maps for Lumia 521

Just got my new Nokia Lumia 521.  When I select the "here maps" from either the start page or the apps page it does not load, just goes back to the start page.  Any help?

Community Manager
poochini21
Posts: 3,556

Re: Here Maps for Lumia 521

Hi bluesmom,

 

Thank you for posting and welcome to the Nokia Support Discussions! :cathappy:

 

Just to verify, do you only get the issue when opening HERE Maps? How about with other navigation applications like HERE Drive? Try to reboot the phone. Don't forget to remove and reinsert the battery before restarting. 

 

Although HERE Maps is preinstalled on the phone, you may also try to remove and redownload it from the Store. Just make sure that before removing HERE Maps, check if it's available in the Store under the Nokia Collection

 

You may also check if there's an update for the app. Normally, applications update show up on the bottom part of the Store homepage. We recommend using Wi-Fi when downloading and installing updates.

 

If the issue continues, try the tricks shown in this link: http://support.microsoft.com/kb/2749480.

 

Hope this information helps. Just feel free to give feedback if this solved your concern. :smileyhappy:

 

 

 


Final Banner
Registered Member
GreatLumia77
Posts: 1

Re: Here Maps for Lumia 521

Hi,

 

I am getting this same issue ever since I updated Here Maps on Oct 17.

I have also updated to the latest Amber updates.

Here Maps is crashing amd going back to the home screen when ever I input any address.

Here Drive worked once but now its crashing too.

Even if I just touch on the maps, its crashing now.

Is this a new bug?