Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: Nokia drive location "freezes" on Lumia 610

New Member
hobbiehobson
Posts: 6

Nokia drive location "freezes" on Lumia 610

Does anyone know how to fix the fact that my location freezes on Nokia drive. It locates me fine then when I drive it stays in same location and sometimes changes every few minutes.
Please use plain text.
New Member
hobbiehobson
Posts: 6

Re: Nokia drive location "freezes" on Lumia 610

I have done both a soft and hard reset, and uninstalled and reinstalled drive. Phone is using windows 7.5
Please use plain text.
Community Manager
musica
Posts: 4,942

Re: Nokia drive location "freezes" on Lumia 610

Hi. Does it only happen to this application? How about when you tried to use other location based services and applications?

Updating the software of the device to WP 7.8 is what I can suggest, by the way. Delivery is in phased manner and availability is subject to operator approval. The roll out is still on going so you can wait until you receive the update notification on your device. You can go to Settings > Phone update.

You can also connect your device to computer and use the Zune software to check for the update. Download option for the Zune is found here: http://www.xbox.com/en-US/Live/Partners/Zune

Cheers.
Nokia Lumia 1020 - nothing comes close Nokia Asha 501 - super smart pocket power 

Follow us on Twitter Watch Nokia Support Videos

Please use plain text.
New Member
hobbiehobson
Posts: 6

Re: Nokia drive location "freezes" on Lumia 610

It is also poor on maps application. I am on orange and update to 7.8 isn't yet? Do you know when it is? Also can I update on Zune beforehand because when I connected to Zune I couldn't find how to go it. Thanks.
Please use plain text.
Community Manager
musica
Posts: 4,942

Re: Nokia drive location "freezes" on Lumia 610

I'm sorry but we don't have information on the delivery schedule of the update on any country or operator.

 

If you went to Settings and then Phone Update and it tells you that there's no update available, it's unlikely that you'll be able to update the device when you connected it to Zune since the update is not yet available at the first place. The best thing to do is to wait until the update becomes available.

 

Once you connected your device to Zune, it will automatically check for the updates. On Zune, you can also go to > Settings > Device > Update. You can read more here: http://www.windowsphone.com/en-US/How-to/wp7/basics/how-do-i-update-my-phone-software

 

Cheers.

 

 

Nokia Lumia 1020 - nothing comes close Nokia Asha 501 - super smart pocket power 

Follow us on Twitter Watch Nokia Support Videos

Please use plain text.
New Member
rpedlow999
Posts: 2

Re: Nokia drive location "freezes" on Lumia 610

Hi

    I have recently bought a lumia 610. I have updated to Win 7.8 and still have the problem people are reporting of drive freezing. It finds the location and plans the route but never starts navigating.  Any suggestions?

 

Please use plain text.
Registered Member
Freddo2
Posts: 2

Re: Nokia drive location "freezes" on Lumia 610

Same problem with my Lumia 920. After a half year it now freezes since a week., plans a route but does not start navigating

I have done resets and uninstall install without any result.

 

Fred Kuipers

Please use plain text.
New Member
rpedlow999
Posts: 2

Re: Nokia drive location "freezes" on Lumia 610

After updating the phone and then doing a reset the GPS is finally working correctly on my lumia 610. I have noticed it can be a little "laggy" but otherwise seems ok.

Please use plain text.