Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

N9 alarm clock does not boot correctly on wakeup

Advisor
felwert
Posts: 11

N9 alarm clock does not boot correctly on wakeup

The N9 alarm clock used to work fine even when switching off the phone: At the defined time, it booted automatically and played the alarm sound, waiting for me to quit it or to sleep for a given time. It seemed to boot into a special mode, as it did not start the complete OS, but instead switched off when quitting the alarm.

 

Since the PR1.2 update, I noticed that sometimes it does not automatically launch the alarm after booting, but instead plays the normal system startup sound, asking me to enter my PIN, then launching the complete OS and only then playing the alarm sound. While it might be handy to have the OS booted after quitting the alarm, there is a major issue with it asking for the PIN: You only receive the startup sound once, and then the phone is quiet again. So if you don’t wake up fast enough and unlock the phone, it will not play the alarm sound repeatedly, which is the whole point of an alarm.

 

It does not happen always, though. E.g. today, it first booted into the alarm mode, but after putting it back to sleep, it then booted into the OS and asked me for my PIN when starting again after the given amount of time. On other days, it asked me for my PIN on the first boot.

 

Any ideas if there is something I can do about this? Or is this a newly introduced bug? 

Please use plain text.
New Member
ahwadar
Posts: 2

Re: N9 alarm clock does not boot correctly on wakeup

Hi, I have the same problem, and filed a bug (bug id 1124) for it:
http://harmattan-bugs.nokia.com/show_bug.cgi?id=1124
I suggest you vote for it to get this issue solved as soon as possible. Cheers
Please use plain text.
Advisor
felwert
Posts: 11

Re: N9 alarm clock does not boot correctly on wakeup

Thanks, ahwadar! Seems like they are looking into it.

I now mostly experienced this after snooze, the first alarm works fine in most cases. But seems quite unpredictable, in general.
Please use plain text.
New Member
ahwadar
Posts: 2

Re: N9 alarm clock does not boot correctly on wakeup

Felwert, do you happen to have the "Toggle PSM" app installed? I'm not entirely sure, but my feeling is that that app is causing the problem. Since I deinstalled it, I haven't had problems anymore.
Please use plain text.