Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: Having a problem turning the phone on

Employee
albertqi
Posts: 18

Re: Having a problem turning the phone on

Hi RajC,

I have met the same phenomenon with my Lumia 800. The phone swith off automaticly after the power is gone absolutely.

The way to solve this issue is to charge more than 10 minutes and then take off the charger from the phone. Then you can power on the phone.(Do not connect with charger when you press the power key)
Please use plain text.
Employee
albertqi
Posts: 18

Re: Having a problem turning the phone on

I used Lumia 800 and I met the simliar symptom as you mentioned. But you can solve the issue by your self.

1, charge the phone for more than 10 minuts.

2, Disconnect the charger.

3, Press power on key to swith on the phone.(The phone must be disconnection with charger)

 

 

Please use plain text.
New Member
epqi999
Posts: 1

Re: Having a problem turning the phone on

I solve the same issue with this way...
Please use plain text.
Registered Member
joeywcy
Posts: 1

Re: Having a problem turning the phone on

I tried this method. It doesn't work. HELP
Please use plain text.
Contributor
Kinslayer
Posts: 5

Re: Having a problem turning the phone on

I have the same issue. Phone won't turn on whatever I do. It did this once or twice before and I was able to get it back on pretty quick, not this time though. Completely dead. 

Please use plain text.
New Member
Anderson21
Posts: 3

Re: Having a problem turning the phone on

I have the same problem. Did the update this morning and tried to make a call this afternoon and the phone just died. One thing though there was a question mark in the battery symbol
Please use plain text.