Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Lumia 620 using mobile data, at home & wifi availa...

Contributor
swright71
Posts: 4

Lumia 620 using mobile data, at home & wifi available

[ Edited ]
In the manual it says that the Lumia 620 will automatically use wifi when available over mobile data. I have my phone connected to my home wifi & this shows as connected on the start screen. My e mail is set to sync every hour. When I've checked my account with virgin the phone is using data at least once per hour, only small amounts but when I'm at home I expected it to use the wifi, yet even overnight it's using the data.
Can anyone tell me what I need to do in my settings to make sure wifi is used when available, my last phone was an N8 & this was never a problem.
Thanks
Please use plain text.
Mobile Sensei
paulheu
Posts: 5,328

Re: Lumia 620 using mobile data, at home & wifi available

 

Make sure you have settings>WiFi>advanced>keep WiFi on when screen times out enabled otherwise once the lockscreen comes up, and you are not on a charger, WiFi disconnects and you switch to your mobile data connection.

 

---


Click on the blue Star Icon below if my advice has helped you or press the 'Accept As Solution' link if I solved your problem..

Please use plain text.
Contributor
swright71
Posts: 4

Re: Lumia 620 using mobile data, at home & wifi available

Hi, thanks for that, however I've just checked my settings & it is enabled, so this can't be the problem. Would be grateful if you ave any further suggestions,
Many thanks
Please use plain text.
Moderator
aleisha11
Posts: 3,050

Re: Lumia 620 using mobile data, at home & wifi available

You have the option to disable the data connection if you're not going to use it. To do this, go to Settings > Cellular or Network > Data connection > Off.

 

Hope this helps. :smileyhappy:


Nokia Lumia 1020 - nothing comes close Nokia Asha 501 - super smart pocket power 

Follow us on Twitter Watch Nokia Support Videos

Please use plain text.
Registered Member
vvvk
Posts: 1

Re: Lumia 620 using mobile data, at home & wifi available

Hey.. Even i'm finding the same problem.. let me know if u got the solution ..

Please use plain text.
Contributor
swright71
Posts: 4

Re: Lumia 620 using mobile data, at home & wifi available

Hi, I realise that I can disable the data, however I don't really want to have the hassle of this all the time when the phone manual tells me that the phone will select wifi over data when available & I've had no problems with previous nokia phones doing this.

Thank you for response though.
Please use plain text.
Contributor
swright71
Posts: 4

Re: Lumia 620 using mobile data, at home & wifi available

I sent the phone back to virgin for them to see if there was a fault with the handset. It's come back doing exactly the same...aargh!
Please use plain text.
Registered Member
aburel
Posts: 1

Re: Lumia 620 using mobile data, at home & wifi available

Had the same problem...try to connect again to your wifi, don t let the ohone to do it automatically...it worked for me
Please use plain text.
Registered Member
Ashokp
Posts: 1

Re: Lumia 620 using mobile data, at home & wifi available

I too had the same problem on my LUMIA 620.

Got tired of this problem and always overran my data limits.
Then I did something illogicaland and unchecked the "WiFi always ON" control and that kept WiFi ON all the time.

Checked the box again and the WiFi started going off.

Now I keep this check box unchecked and everything is sweet.

Looks like on my machine the instructions are working in reverse.

Please use plain text.