Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Lumia 820 YouTube Lags

New Member
SabreTalon
Posts: 1

Lumia 820 YouTube Lags

I recently purchased the Nokia Lumia 820 and for the most part am happy with it.  Unfortunately, though, there are a few things that would dissuade me from recommending this model to a friend or family member.  For one, YouTube does not run smoothly.  I have full WiFi in my home and it's got a good download speed of about 12 Mbps, and the other phones and devices in my house have no problems streaming videos.  There is constant starting and stopping of the video during ANY streaming of video from the YouTube site.  I have yet to see a video clearly without a constant start and stop.  Is there any way to correct this problem or does my phone simply hate YouTube?

Please use plain text.
Ex-Moderator (Retired)
jekiboi20
Posts: 1,733

Re: Lumia 820 YouTube Lags

[ Edited ]

Hi SabreTalon,

 

 

Welcome to the forum!

 

Clearing the cache of your browser might be helpful. To do a clear cache, follow the steps below:

 

  1. Tap Internet Explorer icon Internet Explorer .

  2. Tap options icon settings delete history .


Nokia Lumia 1020 - nothing comes close Nokia Asha 501 - super smart pocket power 

Follow us on Twitter Watch Nokia Support Videos

Please use plain text.
Sage
AndyCalling
Posts: 53

Re: Lumia 820 YouTube Lags

I can confirm that it works fine on my connection, so this is not a generic Lumia 820 issue. I have a 120/12 meg connection, so with a slow old 12meg down connection you may want to change your Youtube settings to low quality stream as default. Also, try disabling all security on your router. If it works, experiment with your router settings to work out what's causing it. Poss. do a router firmware update?

Please use plain text.