Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Lumia 928 Front Camera Not Working

Registered Member
Eisen
Posts: 2

Lumia 928 Front Camera Not Working

I've only had my Lumia for about two weeks and I love it, but all of a sudden the following started happening: when you open the camera app, everything is normal. When you hit the front camera button the screen goes black and the buttons go grey like they are waiting on the camera. Then there is nothing you can do in the app. You have to go to the home screen. Then if you push the camera button on the side of the phone nothing happens. You have to restart the camera from the app list. Then it brings you to the rear camera and the whole process repeats.

I have tried the following to fix the issue:
-Restarted the phone
- Removed and reinserted the SIM card while the phone was off.

If you have any suggestions please share. Thanks.
Please use plain text.
Mobile Overlord
scoobyman
Posts: 10,000

Re: Lumia 928 Front Camera Not Working

Have you installed any "camera" apps recently? you may need to try resetting device as in this resource:http://www.nokia.com/gb-en/support/faq/?action=singleTopic&topic=FA140408 as a pre-cursor to returning device for repair.

 

Unfortunately there have been a number of similar reports with Lumia 920, so don't think Verizon software in your 928 can be blamed here.

Happy to have helped forum in a small way with a Support Ratio = 37.0

Please use plain text.
Registered Member
Eisen
Posts: 2

Re: Lumia 928 Front Camera Not Working

Thanks for the reply. I was hoping I would not have to factory reset, but that is seeming more and more likely to be necessary. Now that you mention it. The front camera stopped working shortly after the instillation and use of the Microsoft app Blink. I uninstalled the app to no avail. If you truly think factory reset is the only option, let me know and I will do it. Thanks
Please use plain text.