Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Nokia Lumia 520 MMS problem with Fido (Solution)

New Member
romaindecarie
Posts: 1

Nokia Lumia 520 MMS problem with Fido (Solution)

I recently bought a Nokia Lumia 520 to use with my Fido (Rogers) sim card. After some time I discovered the horrible truth : I couldn't open media content from my text messages. I called the Nokia Support team who helped me a little but couldn't fix the problem. Fear not fellow Fido users, I have found the solution.

You will have to manually setup your MMS apn on your device.

1. Go to http://www.fido.ca/web/content/phonewarranty/configure_unlocked_device_guide&lang=en

2. Scroll to the end of the page and select "How to configure other smartphones"

What you will see is the info you need to enter in your phone. Keep the window open or write the info down.

3. Take your Nokia Lumia 520. Go to Settings.

On some phones you will have to go to "Access Point" then "Add a New Profile".

If you don't see this first option, go to "Cellular" instead, then at the bottom of the page click on the button "Add MMS APN".

In either case you will have the same fields. So select the MMS APN.

4. Now you will have to fill up the fields with the info from the Fido website. It is pretty straightforward :
APN
Don't put anything in the Username/Password fields
MMSC
MMSC port

5. If you don't have the "proxy" field, just enter the proxy address in the "WAP gateway" field. Be sure to add "http://" before the proxy since it is a URL.

6. Enter the port number (same port than the MMSC port) in the "WAP gateway port" field.

7. If you have the option at the bottom of the page select IPV4 because the proxy is an IPV4. On my phone it was set to IPV6 and it wasn't working until I changed it.

Forget the maximum size option, your Service Provider is already taking care of that.

There, it should be working properly now !

Enjoy.
Please use plain text.