Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: E5: Ovi Suite has lost connection with your de...

New Member
jmoy
Posts: 2

E5: Ovi Suite has lost connection with your device...

[ Edited ]

I am trying to update the software on my E5 using OVI suite but I keep getting an error during the install phase (after backup). The following error and instructions are displayed in the OVI suite window but makes no difference when I follow these instructions (just end up back with the same error).


"Nokia Ovi Suite has lost connection with your device. Follow these steps to help reconnect your device:

1. Remove USB cable from your device.
2. Restart the device (turn off and on again).
3. Re-insert the USB cable.
4. Click 'Ok' below to continue updating."

 

Current E5 software version is 042.007.

I am trying to update to E5 software v. 043.115


Any ideas?

Please use plain text.
New Member
willows73
Posts: 4

Re: E5: Ovi Suite has lost connection with your device...

Yep having the same issue. Just got a replacement handset due to the random restarting issue, soon after setting up the new handset I get a message on phone saying software update is available. Both OVI suite and Nokia software updater say version 43.115 is available (about 200mb in size), I currently have the same version as you 42.007. It claims to do a lot of improvements to the handset. The update downloads fine but when it comes to installing I keep getting the same issue. Phone simply will not restart automatically and the update restarts then fails at the same point over and over. Had the same problem with my previous handset.

 

I spoke with my network provider to see if it was an issue with the handset needing firmware specific to them but they said no it is an issue with the firmware itself and has been happening to everyone since its release!!! They said I should not download it until Nokia has resolved the issues with it. But how do I know when that will happen as I cannot find anything put out by Nokia stating there is an issue or anywhere on web forums saying there is actually a problem.

Please use plain text.
New Member
jmoy
Posts: 2

Re: E5: Ovi Suite has lost connection with your device...

Thanks for the confirmation in any case willows73. I am hoping this update might resolve some other issues I have with the E5 (e.g. can't switch off startup sound, can't access/update OVI store) - can't be sure what this update will actually do since the doc is so sparse.

Please use plain text.
New Member
willows73
Posts: 4

Re: E5: Ovi Suite has lost connection with your device...

An update.

 

Spoke to Nokia UK customer support, they currently deny there are any issues with the new firmware and suggested it is my network provider who are blocking the update. My network provider denies this so Nokia has suggested I take it to a care centre and get them to do the update. The new firmware sounds good so I might do it.

Please use plain text.
Registered Member
tmissenden
Posts: 1

Re: E5: Ovi Suite has lost connection with your device...

I too have started the New Year with this irritating problem. A simple update of the (not  particularly reliable) software and here I am with a dopey bit of technology.

The computer has updated the OVI program happily, I assume, but now the E5 phone won't accept its update. I'm sick of restarting the phone and then getting the same message. If the Ovi suite has lost connection with my device, then it can damn well find it again.

Please use plain text.
Registered Member
egleyes
Posts: 1

Ovi Suite has lost connection with your device...

Same problem when updating my E63, using ovi suite 3.0.0.284 and windows 7. what's the solution guys ? thanks
Please use plain text.
Registered Member
co_ha
Posts: 1

Re: Ovi Suite has lost connection with your device...

Another dead E63 here!

 

Please use plain text.
Registered Member
mahdicho
Posts: 2

Re: Ovi Suite has lost connection with your device...

identical issue here. trying to update a new E5 with ovi suite v3.0.0.284 on windows 7 x64. tried all suggestions but sounds like it's not a problem on our end. never had trouble updating nokia firmware before..

Please use plain text.
New Member
slacker
Posts: 3

Re: Ovi Suite has lost connection with your device...

I have the exact same problem adding this on the off chance they take notice. I am currently on my third handset since November it doesn't bode well for the two year contract i'm in:smileymad:

Please use plain text.
New Member
jonesy1976
Posts: 1

Re: E5: Ovi Suite has lost connection with your device...

Having exactly the same problem as everyone else with my E5, most frustrating. Software downloads fine to my computer and I have tried using both Ovi Suite and Nokia Software Updater to get the firmware onto the phone but the same problem occurs. Judging by the number of comments here this is a common fault with the Firmware/Phone, so come on Nokia, get it sorted. In the mean time if would be a good idea to remove the Firmware update so more customers don't have to go through the frustration of thinking something has gone drastically wrong with their phone!

Please use plain text.
Registered Member
dawn395
Posts: 3

Re: E5: Ovi Suite has lost connection with your device...

Having exactly the same problems and it is driving me mad. Have only had this phone a few weeks and already been replaced. Wondering whether I have done the right thing with this phone. Can anyone advise me on what to do regarding getting caller ID photos to show up and ringtones to play - only 2 out of all my contacts show the photos. Have done a reset yet it stays the same

Please use plain text.
Advisor
kparicharak
Posts: 23

Re: E5: Ovi Suite has lost connection with your device...

People in UK/Europe seem to be getting handset replacement. In India, they just return the same handset declaring the phone is working fine. I have not found a way to reproduce restart problem any time.

Please use plain text.
Contributor
feriso
Posts: 5

Re: E5: Ovi Suite has lost connection with your device...

I have the same issue here with it not updating my handset, now my torch (holding spare) no longer responds so it might be a case of a replacement soon. As for replacement handsets in UK, the UK has laws governing faulty equipment and consumer rights hence they have to replace (or repair after a certain time). Surely India must have similar laws?
Please use plain text.
Contributor
m1bnk
Posts: 9

Re: E5: Ovi Suite has lost connection with your device...

I've got 22 of these for use in the business, all have this fault, and random restart fault. Currently arguing with Orange to take them back and replace with Blackberry. Business can not tolerate a smart phone that has so many problems.
Please use plain text.
Registered Member
PJL500
Posts: 1

Re: E5: Ovi Suite has lost connection with your device...

Exact same problem trying to update my 6303classic. Something systemic happening here with Nokia support?

Please use plain text.
Contributor
m1bnk
Posts: 9

Re: E5: Ovi Suite has lost connection with your device...

Yes, systemic apathy. The fact is they know that most people are locked into an operator contract and therefore they can't just bin the phone and get something else
Please use plain text.
Registered Member
Terry99Binstead
Posts: 1

Re: E5: Ovi Suite has lost connection with your device...

I also have the same recurring program but if Orange, (my network provider) and Nokia are playing ping pong with the problem what other recourse do I have, if any?

Please use plain text.
New Member
ahish07
Posts: 4

Re: E5: Ovi Suite has lost connection with your device...

[ Edited ]

Tats the exact problem E5 is giving me........

 

MODERATOR'S NOTE: This post has been edited. Inappropriate use of words is not allowed in this forum.

Please use plain text.
Registered Member
mpmcmurray
Posts: 2

Re: E5: Ovi Suite has lost connection with your device...

I am relieved that it is not just me. There doesn't seem to be any response from Nokia here??

I have always preferred Nokia phones but might have to consider changing.

 

Why release an update that none of the phones can install?!

Please use plain text.
New Member
guinness_buddy
Posts: 2

Re: E5: Ovi Suite has lost connection with your device...

I've had the problem since the update came out in November/December, and with the latest update of Ovi Suite to 3.1.0.91 that I think came out sometime this week, the E5 firmware update to 043.115 has finally worked!  

 

Apart from Ovi Suite updating itself, nothing on my PC has changed that might influence a successful update.  I hope this has now cleared up this annoying problem for everyone. 

Please use plain text.