Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: E5: Ovi Suite keeps telling me that my device ...

New Member
maartenj86
Posts: 2
Accepted Solution

E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

Hello,

 

I bought the E5 yesterday and today I got to installing everything like it should be. So, I also installed Nokia Ovi Suite to sync everything. But the problem is: I opened Ovi Suite en connected the E5 to my computer with the USB-cable. Then it shows on the E5 which USB-modus I want to select, so I select Pc Suite (as mentioned in Ovi Suite). But I'm asked this 3 times on my E5. On Ovi Suite the device is recognized and it says 'nokia device', so I click on this to select it. But then it says my phone isn't in Pc Suite USB-modus. Obviously, I selected this modus (3 times!!) on the E5... I really don't get it!! Can anybody help me??

 

Thanks,

 

Maarten

Please use plain text.
Registered Member
Markus_ORelius
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

Maarten, I had the same issue and it started after I updated Ovi Suite as well as my device software. I found this in another thread and thought it might help you. I just uninstalled the 3 items and downloaded and installed as prescribed by going to nokia.com/support and downloading and reinstalling Ovi Suite.... Merry Christmas

 

 Re: OVI suite not reconizing the 'OVI suite USB mode 22-Nov-2010 11:36 AM


***** Select Ovi Suite via Tools -> Options -> My device -> Remove this device.

Once you add the device back to Ovi Suite, Select tools -> Add device,
reconfigure the Sync -> Option - device sync settings and sync again.


*****If it does not help:

Go to

Control Panel--> Right click and Programs and Features or add/remove programs
 "Repair" Nokia Ovi Suite.

Go to

Control Panel--> Programs and Features or add/remove programs - > Right click
and "Repair" Nokia Connectivity cable driver & PC Connectivity solution.

 

***** If it does not help:

Uninstall the following Programs,from Control Panel -> Programs and Features or
 Add or Remove Programs.

Nokia Connectivity Cable Driver
Nokia Ovi Suite
PC Connectivity Solution

 

Later download and install the latest OVi Suite from the Nokia.com/support.


 

After OVi Suite installation, restart your PC, disconnect your internet from PC and
connect your mobile to the PC. This is to prevent the PC searching for a new drivers
from internet. OVi suite has all the required drivers for all the nokia phones available
in market.

 

Once all the required drivers are installed automatically, you try connecting the mobile
by selecting

'Connect your device' from the bottom left on the OVi suite screen. You should be able
to connect your device now.

 

 

Please use plain text.
Registered Member
makaveli1976
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

I am running Windows 7 and have just purchased a Nokia N8.  I have the same problem and cant resolve it.

 

Why wont it accept the usb?

 

Ive reinstalled numerous times, ive disconnected internet so drivers are found automatically from ovi suite, but no luck.

 

Im ready to rip my hair out.  How can a new phone not work with a new system and a basic cable.

 

Nokias support didnt help at all. They just told me to remove and reinstall using nokia site (which I told them I have done 15 times).

 

Please help???

Please use plain text.
New Member
maartenj86
Posts: 2

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

The same thing worked for me. Just uninstalling the 3 things mentioned en reinstalling them from nokia.com/support. Then reboot en shut off internet acces and he found my E5 and everything is now syynchronised!!

 

Thanks a lot for the quick response!!

Please use plain text.
Registered Member
weiaaz
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

Yes, thank you my friend, I have installed the suite correctly now. :-)

Just one point, I make my nokia n8 offline in same time in case to avoided error.


Markus_ORelius wrote:

Maarten, I had the same issue and it started after I updated Ovi Suite as well as my device software. I found this in another thread and thought it might help you. I just uninstalled the 3 items and downloaded and installed as prescribed by going to nokia.com/support and downloading and reinstalling Ovi Suite.... Merry Christmas

 

 Re: OVI suite not reconizing the 'OVI suite USB mode 22-Nov-2010 11:36 AM


***** Select Ovi Suite via Tools -> Options -> My device -> Remove this device.

Once you add the device back to Ovi Suite, Select tools -> Add device,
reconfigure the Sync -> Option - device sync settings and sync again.


*****If it does not help:

Go to

Control Panel--> Right click and Programs and Features or add/remove programs
 "Repair" Nokia Ovi Suite.

Go to

Control Panel--> Programs and Features or add/remove programs - > Right click
and "Repair" Nokia Connectivity cable driver & PC Connectivity solution.

 

***** If it does not help:

Uninstall the following Programs,from Control Panel -> Programs and Features or
 Add or Remove Programs.

Nokia Connectivity Cable Driver
Nokia Ovi Suite
PC Connectivity Solution

 

Later download and install the latest OVi Suite from the Nokia.com/support.

 

After OVi Suite installation, restart your PC, disconnect your internet from PC and
connect your mobile to the PC. This is to prevent the PC searching for a new drivers
from internet. OVi suite has all the required drivers for all the nokia phones available
in market.

 

Once all the required drivers are installed automatically, you try connecting the mobile
by selecting

'Connect your device' from the bottom left on the OVi suite screen. You should be able
to connect your device now.

 

 


 

Please use plain text.
Registered Member
tpbfg
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

Good man - and good advice! The 'repair' workaround did the trick for me and my X6, so thanks for that!
Please use plain text.
Registered Member
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

I'm glad someone had some sucess but i'm afraid that none of that worked for me and my 5800 xpress.

 

even downloaded v2 via bit torrent and still tells me that my phone needs to be in PC suite mode..

 

i cannot believe what a useless bunch of .... Nokia are.

 

Any other suggestions ?

Please use plain text.
Registered Member
DIPSIDONUT
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

:smileymad:...I have had no problems syncing my photo's but to-day the little circle that shows it is connecting has been spinning for the last 2 hours and just wont connect....HELPPPPPP plzzzzzz

Please use plain text.
Registered Member
FriendBeaker
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

dear friends. What worked for me was to repair the nokia suite. How? nokia download another suite, then two options. choose repair and done. This worked for me. I hope you also work for them. GREETINGS
Please use plain text.
New Member
77033455
Posts: 1

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

pls sir my phon E5 not connect to internet by nokia suite with USB data cable first its connect but not now .

its show faild connection instblised

Please use plain text.
New Member
murdrav
Posts: 3

Re: E5: Ovi Suite keeps telling me that my device isn't in PC suite USB-modus

With my PC when I connect via USB from the front USB connections the connection is POOR but if I use rear connection it is OK. Has something to do with front connection not having enough power when trying to charge phone I think,
Please use plain text.