Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

MTP Device Driver Problem(Ovisuite + N8)

Advisor
biyer
Posts: 10

MTP Device Driver Problem(Ovisuite + N8)

Sony Vaio Laptop with Windows XP+ SP3

 

I am getting persistent installation problems with MTP device driver(yellow exclamation mark in device manager under portable devices) while installting ovisuite and connectiing it to Nokia N8 over USB. When phone is connected over USB for the first time, all the device drivers except MTP install well. This bahaviour is consistent over many attempts to uninstall 7 reinstall. Ovisuite is able to detect device btw but when I try sync my music- I am getting errors. Any fix for this?

Please use plain text.
Advisor
biyer
Posts: 10

Re: MTP Device Driver Problem(Ovisuite + N8)

Attached are the screen shots of the problem.

 

Additional info: when I select Media Transfer in the Device under connectivity->USB instead of Ovisuite, the MTP exclamation mark in the Device manager goes away and a new yellow exclamation mark against N8-00 appears. When I try to sync downloaded music(from Ovi music) throughv ovi suite I am getting "operation failed- unable to copy the tracks" error.

 

 

Please use plain text.
New Member
hauser
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

I got exact the same problem with my X6.  I have uninstalled OVI suite, all drivers etc. and reinstalled it without any success. Quite frustrating!!!

 

Now I am using pc-suite instead which works ok.

Please use plain text.
Professor
matt_t
Posts: 654

Re: MTP Device Driver Problem(Ovisuite + N8)

I'm having the same problem with my N8 too.  I think it's related to the cable drivers not being fully compatible with the N8.  I've had to manually install all my tunes by connecting the phone in mass storage mode and dragging it all across.

Nokia N8 on O2-UK
Firmware 022.014
Please use plain text.
Advisor
Posts: 24

Re: MTP Device Driver Problem(Ovisuite + N8)

Please use plain text.
New Member
sumeetm90
Posts: 4

Re: MTP Device Driver Problem(Ovisuite + N8)

I have got the exact same problem with my N8. I tried connecting my phone as modem but PC suite didnt recognize the phone. I guess I need to install some driver. Doesnt look like a big problem but its quite frustrating nevertheless.


biyer wrote:

Sony Vaio Laptop with Windows XP+ SP3

 

I am getting persistent installation problems with MTP device driver(yellow exclamation mark in device manager under portable devices) while installting ovisuite and connectiing it to Nokia N8 over USB. When phone is connected over USB for the first time, all the device drivers except MTP install well. This bahaviour is consistent over many attempts to uninstall 7 reinstall. Ovisuite is able to detect device btw but when I try sync my music- I am getting errors. Any fix for this?


 

Please use plain text.
Registered Member
uvwanderer
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

Mowie101 advice does not work for me cause i have WMP12 by default in windows 7

Please use plain text.
Employee
Posts: 1,863

Re: MTP Device Driver Problem(Ovisuite + N8)

Hi,

 

What Nokia OVI Suite version you have installed?

 

(If it is older than 3.0.0.284, update it. And after that try again.)

Please use plain text.
Registered Member
lemoncurd
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

I managed to fix it on mine.

 

I'm using Win 7 and the latest version of OVI. My phone software is the latest etc etc.

 

What I did was uninstall ovi suite, cable driver, nokia software updater (basically everything nokia in programmes/features).

 

I then reinstalled OVI suite again

Plugged my phone in

MTP Driver Installation Failed

Right Clicked Computer, Properties

Device Manager

Right Click, Scan for Hardware Changes on portable devices

A yellow ! will come up next to MTP Device

Right Click, Properties

Device Details, click ok

It will install MTP Device

Close device manager

Right Clicked Computer, Properties

Device Manager

Right click MTP device

scan for hardware changes

it will fail but don't worry at the moment

right click MTP device with yellow!

update driver (or properties and then update driver)

don't search the internet, click let me choose

don't browse, untick the show compatiable drivers box below

in the left window scroll down to Nokia

in the right window choose nokia MTP portable device driver

ignore warnings and click continue and ok

let it install

all fixed.

Please use plain text.
Registered Member
awanz
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

MTP Device Driver cant instaled on my pi first time pls help

Please use plain text.
Registered Member
shash
Posts: 2

Re: MTP Device Driver Problem(Ovisuite + N8)

Thanks, This has solved my problem
Please use plain text.
Registered Member
shash
Posts: 2

Re: MTP Device Driver Problem(Ovisuite + N8)

Thanks lemoncurd,

 

your method hasa solved the problem with MTP Device that I was facing with C2-01


lemoncurd wrote:

I managed to fix it on mine.

 

I'm using Win 7 and the latest version of OVI. My phone software is the latest etc etc.

 

What I did was uninstall ovi suite, cable driver, nokia software updater (basically everything nokia in programmes/features).

 

I then reinstalled OVI suite again

Plugged my phone in

MTP Driver Installation Failed

Right Clicked Computer, Properties

Device Manager

Right Click, Scan for Hardware Changes on portable devices

A yellow ! will come up next to MTP Device

Right Click, Properties

Device Details, click ok

It will install MTP Device

Close device manager

Right Clicked Computer, Properties

Device Manager

Right click MTP device

scan for hardware changes

it will fail but don't worry at the moment

right click MTP device with yellow!

update driver (or properties and then update driver)

don't search the internet, click let me choose

don't browse, untick the show compatiable drivers box below

in the left window scroll down to Nokia

in the right window choose nokia MTP portable device driver

ignore warnings and click continue and ok

let it install

all fixed.


 
Please use plain text.
New Member
GazzaUK
Posts: 4

Re: MTP Device Driver Problem(Ovisuite + N8)

Many Thanks lemoncurd - I too had been plagued for many months by this problem trying to connect my N8-00 - your solution was spot on and seems to have solved the problem! :smileyhappy:

Please use plain text.
Advisor
dragonborn
Posts: 11

Re: MTP Device Driver Problem(Ovisuite + N8)

I got the same problem after I downgraded (flashed) my N8 from Belle to PR 1.0 in order to install different Belle. I noticed I can't flash my device because there's some problem with the USB connectinon. The rest is exactly the same as you decribet it.

 

So I followed you instructions exactly but this (bolded) part was confusing:

 


lemoncurd wrote:

I managed to fix it on mine.

 

I'm using Win 7 and the latest version of OVI. My phone software is the latest etc etc.

 

What I did was uninstall ovi suite, cable driver, nokia software updater (basically everything nokia in programmes/features).

 

I then reinstalled OVI suite again

Plugged my phone in

MTP Driver Installation Failed

Right Clicked Computer, Properties

Device Manager

Right Click, Scan for Hardware Changes on portable devices

A yellow ! will come up next to MTP Device

Right Click, Properties

Device Details, click ok

It will install MTP Device

Close device manager

Right Clicked Computer, Properties

Device Manager

Right click MTP device

scan for hardware changes

it will fail but don't worry at the moment

right click MTP device with yellow!

update driver (or properties and then update driver)

don't search the internet, click let me choose

don't browse, untick the show compatiable drivers box below

in the left window scroll down to Nokia

in the right window choose nokia MTP portable device driver

ignore warnings and click continue and ok

let it install

all fixed.


What I do is:

 

Right click on MTP Device with yellow! -> Properties -> "Details" tab. Over there, there is nothing to but click OK after which NOTHING happens. I don't understand how you got this "It will install MTP Device".

 

Anyway, I continues with the rest of the instructions and at the point where I try to manually update MTP driver by selecting 'Nokia' in the left list and then selecting the MTP driver on the right as you instructed. Then I ignored the warnings and tryed to install the MTP driver. Windows then kindly informed that it has enountered a problem with the installation and it all failed.

 

Any ideas, anyone? I'm desperate!

 

Please use plain text.
Registered Member
dyanburrell
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

I have uploaded a video of my problem...  Hope I can post link here http://youtu.be/V8bTbcZI3RA

Its driving me nuts as no matter what I do as soon as I connect my phone I have flashing hardware found boxes on the bottom right hand side of my screen.

 

Im running windows xp pro sp3 and nokia suite and phone are upto date with everything required.  I have to disable and uninstall MTP Device in order to get my phone recognised by my system.  Before I updated to Belle, after uninstalling MTP Device I didnt have the flashing hardware found at the bottom of my screen after uninstalling, but still showing in device manager as having a problem.

 

Can someone help before I go bald from all the hair Im pulling out.

 

Dyan

x

Please use plain text.
Employee
magovoru
Posts: 345

Re: MTP Device Driver Problem(Ovisuite + N8)

Hi dyanburrell,


First I would try to run repair with your current installation.

 

You can try to repair it in the following way:
- Go to Add/Remove Programs in Control Panel (called Programs and Features in Microsoft Windows 7).
- Select Nokia Suite in the list of applications and click Change/Remove.
- In the dialog that appears, choose Repair. Nokia Suite then checks that all the needed files are intact and repairs any errors that were found.

 

If it does not help, could you try reinstall Nokia suite?
- Go to Program and Features or Add remove in Control Panel
- Click Nokia Suite
- Click Uninstall
Uninstall also:
- Nokia Connectivity Cable Driver
- PC connectivity Solution
Reinstall also device drivers for your device. Go to Control Panel\Devices and Printers if your device is listed there delete it with right click.
- Download and install latest Nokia Suite version from www.nokia.com/nokiasuite
- Restart Computer again
- Connect the device, do not open Nokia Suite and wait for the all driver to be loaded by windows.
- Once done then launch Nokia Suite.
- Check for the issue


This has solved the issue in many cases.


Hopefully this works, if it doesn't - let me know.

 

 

 

Cheers,
Marina
Nokia Suite team

Click on the Star Icon below if my advice has helped you!
Please use plain text.
Registered Member
expert75
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

sir , its quite frustrating i have the same problem with my n8...when i connect my phone ,,and the same problem occurs that mtp usb device driver not installed...i ahve done every steps what u told to do,,,but it doesnt worlk please help me out..,,hoping for +ve result...
Please use plain text.
Registered Member
mma99
Posts: 1

Re: MTP Device Driver Problem(Ovisuite + N8)

This issue had been bothering me for ages and I was getting extremely frustrated with my phone.  This worked for me:

 

Method 2:

If you still come across the issue, I suggest you to run Hardware Troubleshooter and then check for the issue.

If you still come across the issue, I suggest you to run Hardware Troubleshooter and then check for the issue.

a)     Open the Hardware and Devices troubleshooter by clicking the Start button and then clicking Control Panel.

b)     In the search box, type troubleshooter, and then click Troubleshooting. Under Hardware and Sound, click Configure a device.‌

c)       If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

 

 

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/mtp-usb-device-failed-to-install...

Please use plain text.