Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: Ovi Suite + 5230 USB not working

Contributor
zship
Posts: 5
Accepted Solution

Ovi Suite + 5230 USB not working

[ Edited ]

Preamble:

 

I recently connected my Nokia 5230 mobile phone to my PC via USB connection and loaded up Ovi Suite (2.2.1.23). Everything worked lovely. But alas! Both an Ovi suite update was available, as well as a update for the phone itself! So I downloaded the latest version of Ovi Suite (3.0.0.284).

 

Unfortunately, now Ovi Suite does not detect when I select "PC Suite" USB mode (selected on the phone screen). This essentially makes Ovi Suite useless.

 

So I followed some advice on other discussion pages (more on that later) and reinstalled the Ovi Suite. The problem persisted.

 

Here are some pictures to help you understand my problem:

 

http://i.imgur.com/5IknF.jpg

 

The computer is able detect the phone is connected via USB. I can even browse the contents of the phone memory and memory card. Upon detecting the connected phone, and me pressing 'PC Suite' on the phone screen, it will show this:

 

http://i.imgur.com/lV0rs.jpg

 

I cannot progress past this screen. The Ovi Suite simply does not recognise that I've selected that option on the phone.

 

Defense:

 

I know what your thinking. "Just another USB thread". Well, I did in fact read plenty of threads on this forum before posting, and have spent the last few hours uninstalling and reinstalling Ovi Suite and drivers in various ways (as suggested in those threads), with no success.

 

The following is a list of forum threads which I have read and tried all the solutions found in each, and I have copied the solutions (which appear to have worked for other people), for your convenience:

 

/t5/Nokia-Ovi-Suite/Ovi-Suite-PC-Suite-USB-Connection-Problem/td-p/682828

 

Solutions which did not work for me:

 

 


 

Could you please follow these steps and check?
1. Disconnect your phone from PC if connected.
2 .Open Control Panel and go to ‘Programs and Features’
3. From the list of available programs, choose ‘Nokia Connectivity Cable Driver’
4. Click on the ‘Change’ button on top toolbar.
5. In the setup dialog box that pops up next, choose ‘Repair’ and select ok. Wait for setup to complete.
6. Restart the computer if prompted.
7. Now connect your phone to the PC. Driver installation should complete and PC suite (hopefully) should detect your mobile properly now.

 


 

 


 

1. Uninstall all nokia related applications like Ovisuite, pc suite, connectivity cable driver,pc connectivity solutions, nokia software updater etc. from ur PC.
2. Restart your PC
3. Now download and install the recent ovisuite from http://www.ovi.com/suite
4. After installation, disconnect/disable your internet connection (this will make sure that the PC use the drivers which comes with ovisuite and  prevent the PC from downloading any new drivers from internet) and then connect your mobile and wait for drivers and support software installation.
5. After drivers installation you can connect your mobile to ovisuite from ovisuite screen.

Solution which did not work for me:

Hi GannonC,

Uninstall the following Programs, if any, from Control Panel -> Programs and Features or Add or Remove Programs.

Nokia Connectivity Cable Driver
Nokia Ovi Suite
PC Connectivity Solution

Later download and install the latest OVi Suite from the following location.

http://www.ovi.com/suite

 

After OVi Suite installation, restart your PC, disconnect your internet from PC and connect your mobile to the PC. This is to prevent the PC searching for a new drivers from internet. OVi suite has all the required drivers for all the nokia phones available in market.

 

Once all the required drivers are installed automatically, you try connecting the mobile by selecting 'Connect your device' from the bottom left on the OVi suite screen. You should be able to connect your device now.

 

After connecting you can go ahead and update your maps/ download new country maps.

 

NOTE: before updating your maps/ download new country maps, you should have used your maps in you mobile atleast once.

Hope this will resolve your issue.

 

You can connect back your internet anytime after the drivers installation.

 


 

 

/t5/Nokia-Ovi-Suite/OVI-suite-not-reconizing-the-OVI-suite-USB-mode-N8/m-p/809893#M7107

 

Solution which did not work for me:

 

 


 

Hi,

 

Please check the suggestions below:

 

Select Ovi Suite via Tools -> Options -> My device -> Remove this device.

Once you add the device back to Ovi Suite, Select tools -> Add device, reconfigure the Sync -> Option - device sync settings and sync again.


If it does not help:

Go to

Control Panel--> Right click and Programs and Features or add/remove programs   "Repair" Nokia Ovi Suite.

Go to

Control Panel--> Programs and Features or add/remove programs - > Right click and "Repair" Nokia Connectivity cable driver & PC Connectivity solution.

 

If it does not help:

Uninstall the following Programs,from Control Panel -> Programs and Features or Add or Remove Programs.

Nokia Connectivity Cable Driver
Nokia Ovi Suite
PC Connectivity Solution

 

Later download and install the latest OVi Suite from the Nokia.com/support.

 

After OVi Suite installation, restart your PC, disconnect your internet from PC and connect your mobile to the PC. This is to prevent the PC searching for a new drivers from internet. OVi suite has all the required drivers for all the nokia phones available in market.

 

Once all the required drivers are installed automatically, you try connecting the mobile by selecting

'Connect your device' from the bottom left on the OVi suite screen. You should be able to connect your device now.

 

Br

 

Mahyav

 


 

/t5/Nokia-Ovi-Suite/E5-Ovi-Suite-keeps-telling-me-that-my-device-isn-t-in-PC-suite/m-p/856573#M7752

 

Solution which did not work for me:

 

 


 

Maarten, I had the same issue and it started after I updated Ovi Suite as well as my device software. I found this in another thread and thought it might help you. I just uninstalled the 3 items and downloaded and installed as prescribed by going to nokia.com/support and downloading and reinstalling Ovi Suite.... Merry Christmas

 

 Re: OVI suite not reconizing the 'OVI suite USB mode 22-Nov-2010 11:36 AM


***** Select Ovi Suite via Tools -> Options -> My device -> Remove this device.

Once you add the device back to Ovi Suite, Select tools -> Add device,
reconfigure the Sync -> Option - device sync settings and sync again.


*****If it does not help:

Go to

Control Panel--> Right click and Programs and Features or add/remove programs
 "Repair" Nokia Ovi Suite.

Go to

Control Panel--> Programs and Features or add/remove programs - > Right click
and "Repair" Nokia Connectivity cable driver & PC Connectivity solution.

 

***** If it does not help:

Uninstall the following Programs,from Control Panel -> Programs and Features or
 Add or Remove Programs.

Nokia Connectivity Cable Driver
Nokia Ovi Suite
PC Connectivity Solution

 

Later download and install the latest OVi Suite from the Nokia.com/support.

 

After OVi Suite installation, restart your PC, disconnect your internet from PC and
connect your mobile to the PC. This is to prevent the PC searching for a new drivers
from internet. OVi suite has all the required drivers for all the nokia phones available
in market.

 

Once all the required drivers are installed automatically, you try connecting the mobile
by selecting

'Connect your device' from the bottom left on the OVi suite screen. You should be able
to connect your device now.

 


 

 

/t5/Nokia-Ovi-Suite/not-recognizing-USB-mode-on-E73/m-p/780655#M6383

 

Solution which did not work for me (simmilar to above):

 

 


 

frauk:

 

I found this on the Europe forum and it worked for me--finally!

 

From /t5/Nseries-and-S60-Smartphones/Synchronisation-error-code-8393f010/m-p/734155/highlight/true#M21944...

 

  1. Click Start
  2. Click Control Panel
  3. Click Programs and Features or Add/remove Programs
  4. Choose Nokia Nokia Cable Connectivity then Change and repair
  5. Do the same for PC Connectivity Solution - Change then repair
  6. Reboot computer

After re-starting the computer, I also followed this portion of a suggestion from another post (don't know if it made a difference or not):

 

"connected the device, waited till all the drivers were loaded.

Then launched Ovi suite"

 (From /t5/Nokia-Ovi-Suite/E52-Sync-Error-8393f010-838c03ee/m-p/740481)

 

Ovi Suite then recognized my device and the sync appears to have gone smoothly.  I hope it works for you too!  It's ridiculous that it causes so many problems though--I've wasted many hours on something that should have installed correctly the first time.

 


 

Other threads with this problem, which I came across that mention the same problem with various other phones:
More data:
Now that I have shared a detailed description of my failings with you, here is some information about my phone and the Ovi suite:
Phone information (Keypad: *#0000#):

Software version
V 20.0.005

Software version date
23-03-2010

Custom version
20.0.005.C02.01

Custom version date
23-03-2010

Language set
19

Model
5230

Type
RM-588

Latest update
Not needed (<-- is this another bug Nokia? The phone regularly informs me that a update is available...)

Ovi Suite System information:

Nokia Ovi Suite 3.0.0.284

PC Connectivity Solution 10.50.2.0

Connectivity Cable Driver 7.1.36.0

Nokia Ovi Suite Software Updater 2010.44.0.60888

Maps Service API 4.0.24.1

Nokia mPlatform 2.7.44

Ovi Desktop Sync Engine 1.4.1.42

Operating system:
Microsoft Windows Vista 64-bit Edition, Service Pack 2
Language: English

Detected internet browsers:
- Microsoft Internet Explorer 8.0.6001.18999
- Mozilla Firefox 3.6.13 (Default browser)

Detected Bluetooth stacks:
- Microsoft (Version: 6.0.6000, Build: 16386), In use.

Detected USB drivers:
- Default Hub Driver for USB 6.0.6002.18005
- USB Modem Driver 6.0.6002.18005
- EHCI eUSB Miniport Driver 6.0.6002.18005

Additional information:
  • Windows Vista Home Premium SP2 64-bit (with all updates installed)
  • I have no problems with USB or drivers with another components

Zship's revelations:

 

So this is not really a problem for me. I have the working, older (2.2.1.23) version of Ovi Suite installed on my netbook, and sure enough, it works fine, I just tried it. I wont be updating Ovi Suite on it though. I also could probably just download the update via 3.5G using just the phone itself, but the problem remains that a simple software update has caused a critical connectivity problem between your software and hardware. Given that many Nokia customers would have less technical know-how than say, myself or anyone else on this forum, this problem is a quite likely a huge inconvenience to them, they probably wouldn't visit these discussions and spend 5 hours reinstalling software like I just did, and they surely would be thinking twice before purchasing another Nokia device in the future.

 

tl;dr - Nokia recommended update breaks connectivity between software and device, various attempts to fix seemingly simple problem don't work.

Please use plain text.
Contributor
zship
Posts: 5

Re: Ovi Suite + 5230 USB not working

NOS logs attatched.

 

Only joking! Forum does not support it!

The file does not have a valid extension for an attachment. jpg,gif,png,pdf,log,doc,docx are the valid extensions.

Please use plain text.
Employee
Posts: 78

Re: Ovi Suite + 5230 USB not working

Thank you for your feedback.
Could you please provide us the log files?
1. Here are the instructions for attaching log files:
- Open Nokia Ovi Suite 3.0.0.284
- Enable log gathering by double-clicking the enable_logs.js file in installation folder C:\Program Files\Nokia\Nokia Ovi Suite
- Click the button to start enabling the logs when prompted by the dialogue
- Click the button to confirm the "Logs are enabled" dialogue
- Exit Nokia Ovi Suite from File - Exit. This is mandatory! Closing NOS to system tray is not enough!
- Open Nokia Ovi Suite again
- Try to reproduce the error you are reporting
- If the error still exists, double click the collect_logs.js file in installation folder C:\Program Files\Nokia\Nokia Ovi Suite
- Click the button to start collecting the logs when prompted by the dialogue
- Click the button to confirm the "Logs collect & zip finished" dialogue
- Attach the NOS2_logs.zip file in C:\Temp\NOS2 folder and screenshots in the error reporting form
- Go to your %TEMP% folder, which can be found by entering %TEMP% to the Windows Explorer's address bar. Then search debug_log_date.txt in this folder, where date is the current date (or choose the latest one) and attach also this file in the error reporting form. The exact %TEMP% folder paths are:
In XP: C:\Documents and settings\your_username\LocalSettings\Temp\
In Vista and Windows 7: C:\Users\your_username\AppData\Local\Temp\
- Disable log gathering by double-clicking the disable_logs.js file in installation folder C:\Program Files\Nokia\Nokia Ovi Suite
- Click the button to start disabling the logs when prompted by the dialogue
- Click the button to confirm the "Logs are disabled" dialogue

You can send these log files, system information details to ovisuite.feedback@nokia.com mailbox
Please use plain text.
Contributor
zship
Posts: 5

Re: Ovi Suite + 5230 USB not working

I have managed to fix this problem myself, after reading more into the problem.

My solution was to:

  • Disconnect the phone (if connected).
  • Uninstall all Nokia related software: Nokia Connectivity Cable Driver, Nokia Ovi Suite, and PC Connectivity Solution.
  • Download and install the latest Ovi Suite version.
  • Go back and uninstall the Nokia Connectivity Cable Driver.
  • Visit your countries Nokia website. Click 'Support' and then 'Download software'. Now (probably in a drop-down menu) find your way to the 'Cable drivers' section. For me this was at: http://www.nokia.com.au/support/download-software/cable-drivers
  • Download the driver relevant to you, for me it was 'Driver for Nokia DKE-2, DKU-2, CA-42, CA-53, CA-70, CA-101.'
  • Install this driver.
  • Restart computer.
  • Connect the phone, select PC Suite on the phone. If windows starts auto-installing drivers, it may bring up (several) windows asking where to locate drivers. Ignore this for now.
  • Load Ovi Suite. It will load the 'Add device' screen but it will be greyed out and should say "Please wait while USB drivers are installed on your computer". Afterwards, 'Add device' will now actually detect the device properly.


You may need to restart Ovi Suite and/or disconnect the phone a few times to get the last steps to work, it seems that Ovi Suite 'fights' with Windows over which should install the drivers.

 

I have also forwarded the NOS logs as requested in the hopes that this run-around can be be avoided in future releases.

Please use plain text.
New Member
ceemes
Posts: 2

Re: Ovi Suite + 5230 USB not working

Good for you!  Your original listing of "did not work for me" solutions prompted memories, not pleasant, for me.  And your solution is right on.

 

I think that clearing out all Nokia app's before updating  (to OviSuite 3) is key. Windows 7 is pretty plucky and rode over the MTP USB problem this time.  Will probably retry reinstalling a possible alternate cable driver, but right now I am functional.

Cheers,

CS

Please use plain text.
Registered Member
Curiousgal
Posts: 1

Question regarding usb

Hye guys

So i have the nokia 5230 and i recorded a few sound recordings..but now that i connect my usb the listing of the sound recordings dun show up:smileysurprised:. I would like to know how can i transfer my voice recordings from my phone to my computer..

Really need help...thanks!:smileyvery-happy::smileywink:

Please use plain text.
New Member
hifidez
Posts: 4

Re: Ovi Suite + 5230 USB not working

[ Edited ]

zship....    No - not for me it didn't work I'm afraid to say.  I have had exactly the same problem and I followed a similar course to you.   Same issue - all was fine until I installed the new Ovi Suite.

 

Over to you Nokia.............   please, please help me.

 

 

Please use plain text.
Registered Member
Pluton
Posts: 2

Re: Ovi Suite + 5230 USB not working

I have same pb, wtih both X6 and C6

Drivers install correctly. But no sync possible with message opn the phone speeking about expired certifcate.

Anyway i don't need to use this V3 of NOS.

It works perfectly with the older V2xxx

 

But Only one time, because the program ask me to upadte my NOS and if i answer later it close.

I can't use me NOS V2 not more than 2-3 Times

After i'm pbliged to update and pn again.

 

How can i avoid this update ??

Please use plain text.
Registered Member
Pluton
Posts: 2

Re: Ovi Suite + 5230 USB not working

I have same type of pb, wtih both X6 and C6

Drivers install correctly. But no sync possible with message on the phone speeking about expired certificate.

Anyway i don't need to use this V3 of NOS.

It works perfectly with the older V2xxx

 

But only one time, because the program ask me to update my NOS and if i answer later it close.

I can't use my NOS V2 not more than 2 or 3 times

After i'm obliged to update and the same pb comes up again.

 

Is there some knowing how can i avoid this update ??

In order to continue using NOS V2 instead of updating in V3

Please use plain text.
Registered Member
MicroProcessor
Posts: 1

Re: Ovi Suite + 5230 USB not working

It is NOT possible to make the OVI Suite 3.x working with Windows XP

The driver is not working  with XP (error code 39 from WinXP, see microsoft site for explaining this code, unable to load driver, missing files)

 

Solution thar works for me:

Download and install VirtiulBox (free software)

Download from microsoft site evaluationcopy of windowx 7, burn image to dvd

Install Win7 within the virtual machine from virtual box

After installation download and install OVI suite

Connect 5230 to the usb port

Activate usb form the pulldown menu form virtual box (work with admin access)

Win7 detects the phone en installs without problem the drivers

Now it is possible to see and connect the 5230 to Ovi Suite

Please use plain text.
New Member
Iohannes
Posts: 4

Re: Ovi Suite + 5230 USB not working

[ Edited ]

SAME PROBLEM. And none of the many suggested solutions has worked for me yet. I want to thank all on this thread (and many others) for their help. I've learned a lot but I haven't gotten to the bottom of it. I think maybe Nokia needs to ... uh ... bloody well BOTHER TO FIX THIS ISSUE themselves, maybe. Like, cuz they're PAID FOR IT and I'M NOT. Harrumph.

 

I run Windows XP, and was on Media Player 11, but have rolled back to 9 and 10. I have a Nokia E 72. I have all the latest Nokia cable-drivers, PC Suite, OVI Suite, Connectivity software, etc.. The symptoms are as follows: when I plug in the phone by USB cable, the laptop won't recognize it. It says "USB device faulty" or "failed to load properly" and refuses to get the hardware into its brain. The Device Manager shows only a "Unknown Device" which I cannot install drivers onto. Taking the extra media-card out of the phone doesn't make any difference -- nothing I've done will make the computer recognize the main (built-in) card in the phone. I can't browse to it via any sort of populate / repopulate disk drive, or any other method of connecting it.

 

As I understand it, this is some conflict with the phone and the new concept of MTP. Media Transfer Protocol confuses the computer, causing it to kind-of think that the phone is kind-of a media player, when in fact it's a whole lot more. So, the "parent" doesn't get loaded, then the rest of the phone doesn't get loaded, then it kind-of tries to load some MTP but fails, etc.. If I could browse to the phone through a non-Nokia connection I'd be happy to do so in order to implement any of a number of the suggestions above. But I can't get the computer to recognize the phone when the phone is plugged in by USB, regardless of all the solutions above.

 

The problem began a few days ago. It just up and wouldn't recognize the phone. I hadn't installed any updates that I knew of on either item, but it's possible that my memory is faulty and a newer version of this or that snuck in there and screwed it all up. I have tried a serious roll-back to a Restore Point about six weeks old, but that didn't solve the problem. This suggests to me that the problem is phone-resident, since the rollback was to a computer-based Restore Point and I don't have phone rollback capability. 

 

This seriously hampers me. PC Suite, OVI, and some future version of Nokia Suite, will all be useless to me unless Nokia accomplishes the stunning act of supporting their software. I won't hold my breath. Just in general, you'd think that plug-and-play of a phone into your computer would be a lot simpler. Just take the cord -- stick it in the phone; stick it in the computer -- and shazam, you're plugged in. But NOOOOOO we're on NOOOOOOKIA ... Now I know why Microsoft wanted to buy them so badly. They knew they'd all get along and have the same assumptions about software -- that it doesn't really matter whether it works reliably on a user's computer at his home, as long as it works in theory on some programmer's ideal personal computer in Seattle once in a rare while. Nokia? Meet Microsoft. Microsoft? You and Nokia will get along juuuust fiiiine ...

Please use plain text.
Registered Member
Q2Do
Posts: 1

Re: Ovi Suite + 5230 USB not working

Key Step:

 

Temporarily turn off your firewall!

 

I've been at this for hours (what a way to use up annual leave!)

 

I have a Nokia 2730 classic (I know!) and accepted an auto update of Nokia Suite. I then could not connect the phone. I followed all the advice about updating drivers, but when I tried to connect new phone, the mesage "Please wait while USB drivers are updated" just didn't go away - I was deadlocked.

 

Turning off the firewall allowed update of these drivers. Phew!

 

Hope this helps somebody and you don't waste the hours I have (and many others!)

Please use plain text.