Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

problem in nokia c7-00

Contributor
azizkagzi38
Posts: 5

problem in nokia c7-00

i updated my nokia c7-00 to belle but when i tried to start my phone it doesnt start up...it shows the nokia logo and then loading symbol and automatically it will switched off plzz help me thank u

Please use plain text.
Ex-Moderator (Retired)
Puigchild
Posts: 1,287

Re: problem in nokia c7-00

[ Edited ]

Hi azizkagzi38,

 

We're sorry to hear about your problem. It seems that the software update has failed in some way, preventing your phone from booting up normally.  Please see this thread for the most common solutions to this problem.

 

If the issue persists, you should take your phone to the nearest Nokia Care Point and let them have a look. They will be able to flash the phone and re-install software.

 

Let us know how you get on,

 

Puigchild

If you find this post helpful, a click upon the white star at bottom would always be appreciated.
If it also solves your problem, clicking ACCEPT AS SOLUTION below it will benefit other users!
Please use plain text.