Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: Ovi Language

Registered Member
kheric
Posts: 1
Accepted Solution

Ovi Language

I would like to set my Ovi Mail language is Chinese. How can I do?

Please use plain text.
Mobile Sensei
Posts: 7,358

Re: Ovi Language

I don't know if this works, as I haven't tried to change the language to Chinese, but:

 

  • Go to https://mail.ovi.com
  • On the upper left corner, click the "Account" link to go to the Nokia account settings.
  • Then go to "Personal information" and there select "Edit basic information" and change the "Language" selection.
  • Log out and then back in.

I'd assume changing it there, should change the language also for Ovi Mail.

 

Please use plain text.
New Member
farxone
Posts: 3

Re: Ovi Language

no it doesn't work... i have a problem that my ovi mail started popping out in urdu all of a sudden.. now i don't understand a single word on the page and i cannot change back to english... even though my basic settings are on english(US). tried to fix it with the preferences settings on the main page but still as soon as the inbox opens... its all in urdu... and pretty **bleep** translation... i might add... plus the exact translation of english words to urdu makes it sound even more retarded than it should be. PLEASE STOP **bleep**ING AROUND NOKIA... YOU R DOING GREAT... STOP GIVING US LANGUAGE LESSONS BECAUSE WE SURVIVED SO FAR WITHOUT IT. FIX IT BACK TO ENGLISH PLEASE... SO I CAN USE MY ACCOUNT LIKE NORMAL PEOPLE.
Please use plain text.
Technical Expert
svi78
Posts: 427

Re: Ovi Language

Thank you for let us know. To change language on OVI Mail is temporarily malfunctioning and is planned to be resolved by 15 Dec.

Please use plain text.
Counsellor
karim_mohamed
Posts: 50

Re: Ovi Language

Hi All,
kindly try the below steps it will solve your issue
· Login to mail at https://mail.ovi.com/
· Change your URL to https://account.nokia.com/
· Change your Country to one that supports the language you wish your web mail and chat to appear in, and press Save
· Click on Sign Out
· Login to mail at https://mail.ovi.com/
· Accept the Service Terms
· Change your URL to https://account.nokia.com/
· Change your First or Last Name to anything else, and press Save
· Click on Sign Out
· Login to mail at https://mail.ovi.com/ and you will see your new language
Kindly give me Kudos if your problem solved and please mark it as Solved to help others :smileyhappy:
If I've helped in any way, a click upon the white star at bottom right of screen would always be appreciated.

However if my answer also solves your problem clickingbelow it will benefit other users!
Please use plain text.
Technical Expert
svi78
Posts: 427

Re: Ovi Language

I'm are sorry for the inconvenience. This has been fixed now. Please test again.

Please use plain text.
Registered Member
rafiqbroscon
Posts: 1

Re: Ovi Language

Great!
this is good Solution and my problem is solve.
Thanks Man
Please use plain text.
Counsellor
karim_mohamed
Posts: 50

Re: Ovi Language

Hi rafiqbroscon,

kindly mark the problem to be solved to inform others that the problem was solved .
BR,
If I've helped in any way, a click upon the white star at bottom right of screen would always be appreciated.

However if my answer also solves your problem clickingbelow it will benefit other users!
Please use plain text.