Search Discussions:
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: firmware problem

Counsellor
snwang
Posts: 63

Re: firmware problem

[ Edited ]

eshan wrote:

I have the same problem as smwang...whenever i plug out the headphones when the screen is locked on my nokia 5800, the screen light will turn on and remain on forever till the battery discharges completely. same problem happens if i plug out during charging. This problem only happens if the screen is locked.

 

Wrote to nokia care centre and got the same reply as smwang...about restoring to factory setting, which i have done like zillion times...also hv reformatted my memory card million times....

 

sigh, i hv had so many nokia phones previously,,none has given me such a headache before.

 

btw, i'm using the latest firmware..v40.0.005.c02.01


 

Yes, it's a problematic firmware as far as I know for the Asia Pasific 1 phone models. So did you reply to Nokia customer service that their troubleshoot steps doesn't help? I suggest you do so because in my case, they end up offer me to downgrade (swap m/board) to V31.0.101 FOC (still under warranty, of course).

 

I have another European model also running on V40 without such problem. It's close to perfect actually and I like it :smileyhappy:

 

Oh... by the way, the C02 custom code is the color code. C01 - RED, C02 - BLUE. It does not matter which colour you're on, if your region has this issue, both colour codes are affected.

 

Arrgg... one more thing, which region/country does your phone belong to?

Please use plain text.
Mobile Sensei
chanchan05
Posts: 8,090

Re: firmware problem

@ceejay - I dont have a 6220c. All I could say is just do a hard reset.

If you find my post helpful please click the green star on the left under the avatar. Thanks.
Please use plain text.
Counsellor
Posts: 47

Re: firmware problem

@chanchan05 i have done it a kazillion times,its the firmware,it started since i upgraded to v5.15, and my friend who has the same phone but with a older firmware version dosent have that proble

Please use plain text.
Mobile Sensei
chanchan05
Posts: 8,090

Re: firmware problem

Well, I did not see you write in your previous post that you did a hard reset (power off then hold 3, * and green button while powering up), so yeah, that's what I suggested. You could have at least given more detail.

 

Also, check your friend's custom version and check it against yours.

If you find my post helpful please click the green star on the left under the avatar. Thanks.
Please use plain text.
Counsellor
Posts: 47

Re: firmware problem

done the hard reset ,soft reset and 3+star key+green key+power. still same, it is the firmware ,i have even reinstalled the firmware 5.15 again

Please use plain text.
Mobile Sensei
chanchan05
Posts: 8,090

Re: firmware problem

Did you check your firmware custom version and your friend's?

If you find my post helpful please click the green star on the left under the avatar. Thanks.
Please use plain text.
Counsellor
Posts: 47

Re: firmware problem

yes i did he has firmware version 3.46 while mine is the latest 5.15
Please use plain text.
Mobile Sensei
chanchan05
Posts: 8,090

Re: firmware problem

No, no. Custom version is different from firmware version.

 

For example, I have software version 40.0.005, but the custom version is 40.0.005.c02.01...Further more, what are your units product codes?

If you find my post helpful please click the green star on the left under the avatar. Thanks.
Please use plain text.
Counsellor
Posts: 47

Re: firmware problem

my problem was solved yesteday evening,when i did the hard format and i tested the mobile tv on my tv set again and it work fine,

Please use plain text.
Contributor
mikefaulkner
Posts: 9

Re: Nokia 5800 V40.0.005 Firmware Problem

couple of problems i have found with this version of firmware.

 

1,  Will not play video, plays a couple of seconds of video's that worked perfectly well before then stops, audio continues as normal.

 

2. Alarm will not stop, i can put it into snooze by pressing the red button, but i cannot stop the alarm without disabling it.

Please use plain text.
Counsellor
snwang
Posts: 63

Re: Nokia 5800 V40.0.005 Firmware Problem


mikefaulkner wrote:

couple of problems i have found with this version of firmware.

 

1,  Will not play video, plays a couple of seconds of video's that worked perfectly well before then stops, audio continues as normal.

 

2. Alarm will not stop, i can put it into snooze by pressing the red button, but i cannot stop the alarm without disabling it.


 

Mind sharing with us what's the product code and country of your phone?

Please use plain text.
Contributor
mikefaulkner
Posts: 9

Re: Nokia 5800 V40.0.005 Firmware Problem

Sorry, yes Country is UK, and product code is Nokia 5800XM 0577187

Please use plain text.
Counsellor
snwang
Posts: 63

Re: Nokia 5800 V40.0.005 Firmware Problem

Thanks for sharing. I think we should also share the country/product code info as some of these bugs are region specific. For instance the display can't auto turn off bug only happens to the Asian handsets but not the European ones.

Please use plain text.
New Member
gandolfin
Posts: 6

Re: firmware problem

I have had the problem with the screen staying on and not being able to turn it off without pulling the battery. The only solution I have found is to take it to my nearest Nokia repair shop who reinstall the software free of charge within the first 27 months of purchase. They recommend doing this every 8 weeks or so! A very good service, but do back your phone up regularly as this does wipe it!
Please use plain text.
Counsellor
snwang
Posts: 63

Re: firmware problem

Oh.. this is new. Mind letting us know your Product Code and country? By the way, what firmware version you are on now?

Please use plain text.
New Member
gandolfin
Posts: 6

Re: Nokia 5800 V40.0.005 Firmware Problem

I have siilar problem with alarm. get new "band" graphic saying silence or stop and neither do anything!

 

Similar problem when the phone rings and is on autolock. i get a banner graphic coming up saying unlock or answer and again neither works. i have to use the slider switch to unlock and then hit the answer button on the screen.

 

Any advice?

Please use plain text.
New Member
gandolfin
Posts: 6

Re: Nokia 5800 V40.0.005 Firmware Problem

My phone is a UK model 5800 XpressMusic just like the other contributor.

Please use plain text.
New Member
Eckswhyzed
Posts: 3

Re: Nokia 5800 V40.0.005 Firmware Problem

I have a problem with the latest firmware update. When I make a calendar entry and set the alarm to on, when the alarm goes off at the allotted time I cannot turn the alarm off using the "stop" or "silence" buttons, I have to use the red disconnect hardware button on the phone but this just silences the alarm and it comes on again in ten minutes. Any clues on how to fix this?

Please use plain text.
New Member
Eckswhyzed
Posts: 3

Re: Nokia 5800 V40.0.005 Firmware Problem

I am using 5800XM and I am in the UK. Firmware version is v40.0.005.237.06 btw

Please use plain text.
Counsellor
snwang
Posts: 63

Re: Nokia 5800 V40.0.005 Firmware Problem

Yes, confirm I do have this bug (alarm) on my European model.

 

Shall we click on the "Contact us" link and email the developer regarding this issue? I mean no action will be taken if we just rant here.

Please use plain text.