Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Text Messages only show the phone number not the c...

New Member
PeterN8
Posts: 4

Text Messages only show the phone number not the caller name from my address book after Belle update

I've updated to Belle on my N8 and all my text messages and my address book restored fine.

 

But all my text messages in my inbox (and all the new ones I receive) just show the callers number, it doesn't find the person's name in the address book. 

 

Obviously, it didn't used to do this on Anna and Symbian^3. 

 

I tried re-synching the messages from Nokia's desktop software but this didn't make any difference. 

 

Has this happened to anyone else, and does anyone have a solution? 

Please use plain text.
Mobile Guru
rayhipkiss
Posts: 3,937

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

  


PeterN8 wrote:

I've updated to Belle on my N8 and all my text messages and my address book restored fine.

 

But all my text messages in my inbox (and all the new ones I receive) just show the callers number, it doesn't find the person's name in the address book. 

 

Obviously, it didn't used to do this on Anna and Symbian^3. 

 

I tried re-synching the messages from Nokia's desktop software but this didn't make any difference. 

 

Has this happened to anyone else, and does anyone have a solution? 


 This issue is always caused by having duplicate contact/s and/or having the same number stored under more than one name or location. 

 

Ray. 

Please use plain text.
New Member
PeterN8
Posts: 4

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Thanks for that advice Ray.

 

I see the logic behind it but I don't have any duplicate contacts in my phone and this problem has suddenly affected every single text message I have after the update. 

Please use plain text.
Mobile Guru
rayhipkiss
Posts: 3,937

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

 

 Ok then, have a read of the following for an alternative solution.

 

/t5/Pool-of-Knowledge/Missing-Caller-ID-on-Calls-SMS/m-p/371913

 

All the best.

 

Ray. 

Please use plain text.
New Member
PeterN8
Posts: 4

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Thanks again Ray, I've looked at all of those but none of them check out. 

 

Even more mysteriously when I look in the normal inbox all the messages do now (without me changing anything) have the correct names. 

 

But in conversation view it still just shows the numbers. 

Please use plain text.
New Member
wdsol
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Hi - I had exactly the same problem (though on E7 rather than N8) - was doing my head in. 

 

Try flipping the contacts to show contacts from the SIM, then back to the phone. (Contacts -> Settings -> Contacts to display)

 

Worked for me

 

Cheers, Dan

Please use plain text.
Registered Member
Posts: 3

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Thank you very much "wdsol" had the same problem with my n8 a few days suddenly after updating to belle, This solution hasd worked for me, hope it doesnt happen again. Cheers. :-)
Please use plain text.
Registered Member
al_is_on
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

[ Edited ]

Hi! Thanks "wdsol" for the tip! It worked to me too.

Nice!

Please use plain text.
Registered Member
Jane_TT
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle up


wdsol wrote:

Hi - I had exactly the same problem (though on E7 rather than N8) - was doing my head in. 

 

Try flipping the contacts to show contacts from the SIM, then back to the phone. (Contacts -> Settings -> Contacts to display)

 

Worked for me

 

Cheers, Dan



Thanks wdsol, had the same issue on my N8 for a few weeks since upgrading to Belle, it works perfectly now!.

 

Cheers Jane

Please use plain text.
Registered Member
rakeshnair2005
Posts: 2

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

@wdsol Thank you :smileyhappy:
Please use plain text.
Registered Member
Ranoman
Posts: 3

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Thanks mate, that was doing my head in!

Please use plain text.
Registered Member
minal26
Posts: 2

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

hey, this really worked for me. thanks a lot.

Please use plain text.
Contributor
motorhead1979
Posts: 6

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

 

 

In my case, I had some old versions of my contacts data backed up to the SIM card.

 

In Contacts->Settings, tap Contacts to display, select only SIM memory, tap OK. It'll automatically change Default saving memory to SIM memory, which is okay for now. Go back to main Contacts view, Mark All, and Delete! Now go back to Settings and change Contacts to display and Default saving memory back to Phone memory. That's it!

 

Don't copy your contacts to the SIM card, ever! Use a PC or Nokia Sync.

 

 

Please use plain text.
Registered Member
comesbackatlast
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Thank you!
Please use plain text.
Registered Member
extros_deinos
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

Hi there. I`ve been having trouble with this on my N95-8gb and on my N8 and changing contacts dir seems to do the trick.

 

Thx.

Please use plain text.
New Member
dsun184
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

@wdsol Thanks. Flipping the contacts worked for me.

 

Incidentally, I noticed that the issue of the Contact Names not displaying in Conversations View started happening for me immediately after I received a text message from a friend who was abroad (in Spain, I'm in Ireland btw).

 

Exact same thing happened a few months prior (message also from Spain). Not sure if this is just coincidence... but just thought I'd mention it. Anyone else experience that same thing? Can anyone check if a text from abroad is the trigger?

Please use plain text.
Contributor
pengduoming
Posts: 7

Re: Text Messages only show the phone number not the caller name from my address book after Belle up

This just happened to me after an update Nokia suggested I make (for calendar and something else). Really annoying but glad I found this thread as wdsol's advice worked for me too.

 

I thought it was because I had firmware that enabled reading and writing in Chinese, as I remember this problem was inherent in the official Chinese version and the only fix was to install another (Singapore?) version to enable being able to use Chinese and have contact names in both call and message view.

Please use plain text.
Registered Member
Rmph
Posts: 1

Re: Text Messages only show the phone number not the caller name from my address book after Belle update

I found that as I list my contact 555-1212 my phone see them as +1555-555-1212

So I just had to add +1555 in front of my numbers saved in my contacts! Problem solved!!😁
Please use plain text.