Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

5800 and WIFI

Contributor
Posts: 8
Accepted Solution

5800 and WIFI

I have problems connetcing through my wireless home network.  I apperently get connected to my lokal wireless router, but I'm not able to get to the Internet; I opens my browser, click a shortcut but after at short while I get the message "No info from gateway".

 

Connecting through Edge/3G works fine.

 

Anyone who can help?

Please use plain text.
Mobile Overlord
cjlim
Posts: 16,962

Re: 5800 and WIFI

If you are getting a "No gateway" message also try the following:

1. Check to see if MAC filtering is enabled on your router, if it is, you will need to add the MAC address of your phone to the "allowed" list. Use the code *#62209526# to get your phones MAC address.

2. On your pc/laptop, click on Start>Run and type ipconfig/all and note the settings for:

a) Subnet Mask

b) Default Gateway

c) DNS Servers


Now, on your Phone settings: Goto Menu>tools>settings>connection>access points

Select your WLAN access point and go to Advanced settings:

IPv4 settings:

For phone IP address: Start with the Default Gateway IP and change the last number to something else.
For Subnet mask and Default gateway use the same as on PC
For DNS address: Change to user defined and enter same settings as on PC

3. Check for firmware updates for your router and install if there is one.

4. Disable WirelessLAN Power saving mode. To do this, goto Tools>Settings>Connection>Wireless LAN>Options>Advanced settings>Automatic configuration>change>Power saving, set this to disabled.

Please use plain text.
Contributor
Posts: 8

Re: 5800 and WIFI

Thanks for suggestion! 

 

I have tried both manual and auto config, and finaly I also have succeded connecting.  The problem now is that once I have made a connection the next moment I get the answer "No reply from gateway".  Then it is back to start and try to connect again.

Please use plain text.
Mobile Overlord
cjlim
Posts: 16,962

Re: 5800 and WIFI

What IP address did you use and what are the IP addresses of your gateway and pc?

Please use plain text.
Contributor
Posts: 8

Re: 5800 and WIFI

On my phone I have tried both Automatic (DHCP?) and User specified.  With user specified I have uesed a number in my range: 10.0.0.5, gateway is 10.0.0.138, pc IP adr is 10.0.0.3.
Please use plain text.
Mobile Overlord
cjlim
Posts: 16,962

Re: 5800 and WIFI

[ Edited ]

That sounds reasonable.

 

Have you checked for firmware updates for your router? Install updates if available. 

 

You could also start testing with different channels settings on your router. Long shot but it has been known to work.  

Message Edited by cjlim on 24-Nov-2009 09:20 AM

Please use plain text.
Contributor
Posts: 8

Re: 5800 and WIFI

I have a speedtouch router, and the latest tip is to switch off qos on the router. 

 

Telnet to the router: 

{admin}=>wireless qos config mode=disabled
{admin}=>saveall

 

I will try it later this evening.

Please use plain text.
Contributor
Posts: 8

Re: 5800 and WIFI

Case closed!

 

Disabling QoS on the router solved the problem.

Please use plain text.
Registered Member
OrenX
Posts: 2

Re: 5800 and WIFI

Hello,

 

I would really appreciate any help with this one.  I have wifi at home.  But I also might want to use it in a cafe or something.  When you use wifi on a labtop, you are asked to enter a username and password.  NOT an "WEP" code of 26 hexidecimal digits or other crazy things I have seen mentioned.

 

So I don't understand how to connect to wifi say at home or elsewhere.   Should I use the "ad hoc" option, etc.

 

Thanks very much.

 

Oren

oren.benbassat@gmail.com

Please use plain text.
Registered Member
OrenX
Posts: 2

Re: 5800 and WIFI

Also: Is a WEP and an IP address the same thing?!

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: 5800 and WIFI

 


OrenX wrote:

Also: Is a WEP and an IP address the same thing?!


A website address is translated to an IP address. WEP ( not recommanded) is a security key. It's better to use a WPA-PSK/WPA2-PSK key. Use Infrastructure in stead of Ad-Hoc in the set up of your accesspoint.

 

‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Advisor
mobilemarket
Posts: 21

Re: 5800 and WIFI

This worked for me:

This works on Windows 7.

1. Under network and sharing centre, click "change adapter settings" on the left.
2. Turn your wifi adapter on, right click it and choose properties.
3. If there is a tab called sharing, click it and unmark the two checkboxes there. OK.
4. Do the same for LAN adapter.
5. Select both your Wifi and LAN adapter at the same time. right click one of them and choose bridge connections.
6. Go to wireless network management and create an unprotected ad-hoc network and mark the "save this network" option so it won't disappear after you disconnect from it.
7. That's it. First connect to the created ad-hoc network in windows and then with your phone.

Works like a charm for me. I have had no problems connecting to the internet, not even after restarting.

P.S. A Kodus is a must if it works for you :smileywink:
Please use plain text.
Advisor
mobilemarket
Posts: 21

Re: 5800 and WIFI

First try with the 'Open' (unprotected) ad-hoc network, if it works you may try to use the WEP. I tried it and it worked for me with WEP. :smileyhappy:
Please use plain text.
Advisor
mobilemarket
Posts: 21

Re: 5800 and WIFI

Well, it may not work with the WEP thing. Try using the unprotected adhoc netwrok.

Please use plain text.
Advisor
sENSIS
Posts: 18

Re: 5800 and WIFI

Hi all.

@OrenX: at cybercafes and public WiFi hotspots, it's normal to have unprotected wireless networks, so it does ask for a WLAN password. At a cybercafe, you probably need to pay to use the internet, so they will provide a username and a password for you to be able to access the internet. The simple fact that you see a web page asking for you to login, means that you are connected to the wireless network.
Please use plain text.
Registered Member
pkatkam9
Posts: 1

Re: 5800 and WIFI

:w00t: BEST SOLUTION ALTHOUGH SIMPLE... I HAVE TRIED ... AND TRIED.... BUT NOW I GOT IT... AMAZING SOLUTION

Please use plain text.