Search Discussions:


Showing results for 
Search instead for 
Do you mean 
Advanced search
Welcome to our community! Here you can share advice and tips with thousands of other Microsoft mobile devices users around the world in English. Please take a moment to read our community guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others you need to sign in first. If this is your first time here, you can choose an alias to represent you. If you don't have an account yet, please register here.
Reply

C3- GPRS always on

Contributor
dragonmate
Posts: 3
Accepted Solution

C3- GPRS always on

I noticed that GPRS gets activated on its own.  Packet data connectivity is set to "when needed" and network connectivity of all applications are set to "ask every time".  I can't find a way to turn off the GPRS connection.  Even if I turn off the phone-- remove the battery and SIM card as advised by Nokia help line-- the GPRS still activates a few seconds after the phone is turned back on.

Mobile Overlord
jimmyireland
Posts: 17,360

Re: C3- GPRS always on

do you have any apps that require an internet connection like email.
what network are you on?

If  i have helped at all a click on the white star below would be nice thanks.



Now using the Lumia 1520
Sage
ryanismo
Posts: 225

Re: C3- GPRS always on

Try checking the Phone software update and Communities settings.
500.21.009
02-06-2010
RM-346
Nokia E71-1 (27)
Mobile Overlord
jimmyireland
Posts: 17,360

Re: C3- GPRS always on

the software has nothing to do with that

If  i have helped at all a click on the white star below would be nice thanks.



Now using the Lumia 1520
Contributor
dragonmate
Posts: 3

Re: C3- GPRS always on-- SOLVED!

It was the Facebook app in Communities, which was set to access the network at certain times of the day.  Thanks to all!

Mobile Overlord
jimmyireland
Posts: 17,360

Re: C3- GPRS always on

as i asked did you have any apps that need an internet connection

If  i have helped at all a click on the white star below would be nice thanks.



Now using the Lumia 1520
Sage
ryanismo
Posts: 225

Re: C3- GPRS always on

See? ;-)
500.21.009
02-06-2010
RM-346
Nokia E71-1 (27)
Counsellor
Domii
Posts: 15

Re: C3- GPRS always on

[ Edited ]

At the moment my C3 requires permanetly an internet connection for some reason. It used to go through GPRS but with some settings it chooses WLAN over GPRS now. If I try to disconnect the WIFI connection then it says "Active Connection will be lost.". I have no idea what active connection is online, I only use internet, Nokia email and chat. I checked those apps for connection and all automatic connections are off. Please, can someone help me? Btw, the mean thing is, that I get charged for it. I'm on Vodafone...

Professor
chromecat
Posts: 207

Re: C3- GPRS always on

I'm trying to collect all the phone settings that might generate automatic data transfer in the background. If you are find something I forgot or if I made an error here, please correct it.

 

Communities Application

In Communities->Settings there's a Minimize my data use checkbox and the description says: Stop all automatic downloading of text and pictures. When it is disabled, automatic connections might occur.

 

Also there's another option Automatically update my phone Home screen: and a time interval or never.  This is because you can add the Communities app to the Home screen, and the app might establish connections to update the widget on the Home screen during the specified interval.

 

Nokia Mail Application

 

In Mail->Settings there's an option When roaming: with the options Minimize costs or Follow my account settings. When the setting is Minimize costs, no automatic data transfer should initiated by the app.

 

Also there's an option in Nokia Mail, when an account is selected: Options->More->Settings->Update my inbox. When it is set to Fast or Very Fast, the phone automatically updates the contents of that account. This is marked by a @ icon on the notification area. No data transfer should occur on the account if it is set to Manual.

 

Chat Application


There are no related settings here, but when you do not log off from an account, only hide the app (this is denoted by a green dot in the notification area), data transfer occurs in the background.

 

I don't know how these settings interact though.

 

Nokia Lumia 520 3046.0000.1329.2001 RM-914
Nokia Asha 302 V15.09 22-05-13 RM-813
Counsellor
Domii
Posts: 15

Re: C3- GPRS always on

Thanks for your help and suggestions. Really appreciated!


I just tried to set my email updates to "manual" and after a reboot of the phone the automatic connection seems to be really gone. I hope it'll be like that constantly now. I only wonder why I got charged even with WIFI... :smileyindifferent:

Thanks again!

Registered Member
niknix1234
Posts: 1

Re: C3- GPRS always on

I had the same problem and tried all these things but couldnt work out what could possibly still be connected.  I then realised I had Snaptu installed on my phone and in that Facebook which I was signed in to!  Finally got there in the end.  Good advice :smileyhappy:

Counsellor
rpospisi
Posts: 21

Re: C3- GPRS always on

You can try Roaming Guard, which monitors the application access to the internet and, according to selected settings, enables or denies this access.

Registered Member
hemant1611
Posts: 1

Re: C3- GPRS always on

Hi

 

Actually in Nokia Mail Application i am able to find "Mail->Settings there's an option When roaming" and changed it to Minimize costs but my problem is i am not able to find "Options->More->Settings->Update my inbox" OPTION.....

 

after changing also an "E" icon is coming at my home screen. i want that my phone should not be connected to GPRS always only connects when i want it...

 

Please help.

Professor
chromecat
Posts: 207

Re: C3- GPRS always on

The Minimize costs option merely disables automatic updates when roaming.

 

There's no "Update my inbox option." Your inbox is updated when you click on the selected

mailbox account.

 

The E icon means your phone tries to use an EDGE connection. It should use a WLAN connection when available. Of course you should be in a vicinity of a WLAN AP and have the access credentials entered correctly.

 

What is your firmware version? (Enter *#0000# to find out). Try updating to the latest. 4.45 fixed some connectivity issues.

 

Make sure that Settings->Connectivity->Packet Data->Packet Data Connection is set to "When needed".

 

Make sure that Settings->Connectivity->WLAN->Internet Connection is set to "Ask First".

 

This thread: link might give you some hints on WLAN issues. Also, use the Site search feature.

 

Hope that helps.

 

 

Nokia Lumia 520 3046.0000.1329.2001 RM-914
Nokia Asha 302 V15.09 22-05-13 RM-813
Contributor
Ange74
Posts: 3

Re: C3- GPRS always on

My husband has just bought a Nokia C3, same as mine, on o2.. -  I've just looked on this site at the post that Charlie222 put on with the correct settings, which worked for my phone. - However, my husband's phone has a different menu to mine, it doesn't have 'internet settings', which means he can't make it 'ask first', it just connects to the internet instead of using wi-fi. - Please can someone help.

 

I know you're supposed to go to 'internet settings' then 'web settings', but this option is not even there on his phone.

New Member
faheem85
Posts: 2

Re: C3- GPRS always on

not solved for me guys, i having the same issue. soon i turn on my C3, the E signs appears n start eating my balance. i have setup all updates to manual, in mail, in communities and chat, though there are not much options for automatic updates in chat. the packet data is set to when needed, and even WLAN set to ask first. i have also noticed that soon i disconnect my cell from WLAN the E sign appears and it connects to the GPRS. E signs stay on home screen even after closing all apps, and i have checked in the log that data timers and data counter both are running, when there is nothing is on. so finally to stop GPRS from eating up my all balance i have deactivated my GPRS from the operator. my operator is suggesting me to set ur phone to factory settings but i have'nt tried because i might lose my all contacts, notes n messages. Please help :-)

Professor
chromecat
Posts: 207

Re: C3- GPRS always on

The E sign is shown when there's an established EDGE connection. The [E] sign is displayed (boxed E) when there's data transmitted over the EDGE connection.

 

Are you sure that data is transmitted?

 

Also, check other applications (if you installed any) that might establish network connection (Snaptu, Facebook, whatever).

 

 

Nokia Lumia 520 3046.0000.1329.2001 RM-914
Nokia Asha 302 V15.09 22-05-13 RM-813
New Member
suCH
Posts: 1

Re: C3- GPRS always on

[ Edited ]

 As has been mentioned in other replies, the problem seems to lie in a programme/application that is trying to access the net. Not all applications let us know the change in settings that they bring about .

 

My C3 was  connecting to WLAN or EDGE automatically. When I would manually switch off WLAN the phone would connect to EDGE automatically. Also there seemed to be no way that I could get rid of the [E] symbol. Though I had set the 'Always Ask' option for accessing the internet, I was losing credit. I didn't know how.

 

I tried to recollect applications that I had subscribed to recently. One of them was Ovi e-mail. I changed the inbox settings as has been suggested in some of the replies in this forum. It was of no help. Finally I deleted the Ovi account. This got rid of the problem.

 

I would suggest that you try to remember any mail account or social networking site that you had subscribed to recently and then try to change the settings or delete the account. Then you can resubscribe to a GPR service.

 

 

Registered Member
usman_azhar
Posts: 1

Re: C3- GPRS always on

restore fectory settings then problem will be solved.

New Member
kaybee6611
Posts: 2

Re: C3- GPRS always on

:smileyhappy:

hey, this worked for me: look for FLIGHT PROFILE, activate it for a few second (which will terminate all active connections) then reactivate your preferred profile and **bleep**! the GPRS connection will be terminated! :smileyvery-happy: tell me if it works.