Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrad...

Contributor
goddies
Posts: 5

E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Good Day

 

I upgraded my E7-00 to belle the other day, the wifi keeps dropping its connection.

 

I have two wifi points that I use it does not even swop over between them. It just drops the connection which has to be manually re-established.  Often the phone has to be rebooted as it just wont reconnect to the wifi.

 

Under Anna it worked reasonably well. I never had any of these issues.

 

In comparison my Nokia E90 is rock solid and I have no issues with the wifi at all.

 

This phone has so much promise to be a really great tool but is stuffed up by one sloppy upgrade after another.

 

Will a update to Belle be released soon fixing these issues and others.

 

Thank you.

 

Kind regards

 

Godfrey

Please use plain text.
Ex-Moderator (Retired)
Iris9290
Posts: 1,302

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Hi goddies,

 

Welcome to the Nokia forum.

 

First, go to your Connectivity Menu via Menu>Settings>Connectivity> WLAN. Press and hold your WiFi connection and choose Remove. Then reconnect and see if this makes a difference. 

 

If this doesn't work, try a hard reset with *#7370#. The default security code is 12345, unless you've changed this yourself. Don't forget to make a backup. Once you've done the reset, place the backup back onto your phone and reinstall Belle. This will clear up any errors, bugs and unnecessary data and should let you connect to the WiFi as before. 

 

Now, go back to your WLAN settings as explained above and remove and add the connection. You should now be able to connect to your WiFi connection as before. 

 

Hope this helps, let me know how you get on!

 

Iris9290

If my post has helped you in any way, please accept it as a solution or click on the white star, so that other users will be able to benefit from it too.
Please use plain text.
Advisor
paolo_f
Posts: 14

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Good day,

I have a problem also with my WIFI after Belle Upgrade.
It seems that when I leave my WIFI off for quite some time and put it back on, my E7 does not connect to the WIFI network.
It just keeps on "Connecting" then drop over and over again.
The solution is to reboot the phone.
Anyone experiences the same?
Thanks.
Please use plain text.
Ex-Moderator (Retired)
Iris9290
Posts: 1,302

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Hi paolo_f,

 

Please follow the steps I've provided below and that should also fix the issue you are having. 

 

Let me know how you get on!

 

Iris9290

If my post has helped you in any way, please accept it as a solution or click on the white star, so that other users will be able to benefit from it too.
Please use plain text.
Sage
dumpystig
Posts: 82

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Haha thanks for this tip!

 

I've had my E7 for 48 hours and tonight I've been trying to sort this same problem of WiFi continually disconnecting after about a minute. Just rebooted and now when I wake my screen I'm confronted by the 'connected' wireless beacon. So simple yet I've been stumped until now.

 

Thanks again   :smileywink:

 

Please use plain text.
Advisor
angurbeats
Posts: 12

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

  I am having problem with my wi fi on E7.  Before updating I had no problems connecting to my BT hub with wi fi. But after updating I can not connect and when I do (no one is going to believe me on this)all my wireless connections in the house drops and i have to reset mu hub, but there is no internet data being received or sent on my phone.  but the phone shows its connected but no data being received  or sent.  First my understanding was the hub is not working.  BT has replaced my hub,  I am still having the same problem.  I have tried it with other wireless networks as well with no success. 

 

I have followed your guide.  but I am still having the same problems.  i know there is no chance of re-installing  ANNA back on the phone but i had no problems at all.  i have always loved nokia and the E7 made it perfect until now.  please help me my phone is out o\f warranty now.

Please use plain text.
New Member
Romyo2
Posts: 3

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

I have the same problem with my E7-00
I tried to reset the phone ,,, removed All 3'd Party Apps ,,,, didn't work still the same problem !!
and the only way to make it work again is by restarting the phone :\
Please use plain text.
New Member
mariusmaz
Posts: 4

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

wifi is definitely buggy in Belle. I have the same problems, even after following the steps above. The connection drops randomly, and eventually it remains stuck with the status shown as connected but no data actually coming or going.

Then, the only way to connect is to turn off and restart the phone; but if I use the conncetion, in a couple of hours I'm back to the same stuck concetion that needs a restart.

Please use plain text.
Advisor
angurbeats
Posts: 12

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

i want to point out another problem. maps dont work aswell
Please use plain text.
New Member
glaren
Posts: 1

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

any update on this, i can connect again only after rebooting

Please use plain text.
Advisor
angurbeats
Posts: 12

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

hiya dumpystig could you tell us how you did it please.
Please use plain text.
Contributor
goddies
Posts: 5

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Good Day.

 

I have some feed back for you.

 

I reset my phone as you instructed with *#7370#. This reset turned my life upside down as all the customisations etc were reset.

 

After a good few days of testing I regret to report that the same troubles continue. I have visited various customers/friends of mine and tested the phone on their wifi networks to see what transpires.

 

This problem is NOT related to my wifi set up but a fault with Belle.

 

The first version of the phone software that it came with the wifi was terrible could not hold a signal.  This was bearable under Anna.  Under Belle it connects then drops the signal.

 

I would like some feed back from you as to what steps Nokia will take to correct this deficiency of the phone software in Belle.

 

Thank you

 

Godfey

Please use plain text.
Advisor
angurbeats
Posts: 12

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

I have been a loyal customer with Nokia since 1998 from the banana grins onwards. I know most of us here have been.  Even though so many contract upgrade with the chance of changing to other phones, we all stayed with Nokia.  Its seems we have been loyal but Nokia has ignored us.  They don't seem to care any more.  From what I see now its best to move on.  Just got a lumia 800 as well.  But I think I will move on other products now.  Better of with apple.  If they cared all they had to do is make Anna into a upgrade with zome code changes. So the phone recognises this as an upgrade.  Am sure this will not take that long for the coders.  Here's me saying bye bye to Nokia for what they done to us.

Please use plain text.
New Member
Salvo1
Posts: 1

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

I am now on my third Nokia E7-00 as I  try and sort out why the wifi keeps dropping after update to Symbian Belle. When I was using Sybiam Anna the wifi was working fine. Does anyone know when and if there is going to be a Symbian Belle fix for this problem?  Or can I roll back my phone to the Symbian Anna operating system? thanks

Please use plain text.
Registered Member
Angbadang001
Posts: 1

Re: E7-00 Wfi Unstable/Keeps dropping after Upgrade to Belle

Hello!

 

This issue with the latest update to Belle has had the same effect on my E7. However, instead of rebooting the whole phone I experienced that a swap to the "Offline" profile and back to any profile with wifi enabled worked just as well. This may save everyone with this problem a few valuable minutes each day.

The easiest way to switch profiles is to use the powerbutton however you could also do it via the Menu> Settings> Profiles.

Hope this helps!

Please use plain text.