Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: N8 - MMS access point issues

Contributor
Posts: 6
Accepted Solution

N8 - MMS access point issues

The access points automatically configured when I put Vodafone UK PAYG SIM in my N8 were incorrect, so I had to manually change the access point names to "pp.vodafone.co.uk". However, I can't find where I can change the "Vodafone MMS" access point setting - it seems to have disappeared from the Destinations list.

 

So, I manually configured a new access point, using a different name, and selected this in the Messaging settings. Messy, but I can at least send MMS messages.

 

However, the Log shows that the N8 still attempts to connect to the incorrect "Vodafone MMS" access point every minute, or so, which presumably is going to drain the battery. I can't work out why it is doing this ... no application should be using that access point, from what I can see. The only way I've found to stop this is to set "Data use in home network" to WLAN only - but that means I have to change the settings before I can use network data.

 

How can I change/delete an automatically configured "Vodafone MMS" access point setting?

 

How can I stop the N8 from trying to connect to this access point every 60 seconds, without disabling network data completely?

 

Cheers.

Please use plain text.
Counsellor
Posts: 69

Re: N8 - MMS access point issues

I also want to delete the preset mms setting of my N8 cuz it tries to use it for app's and widget's and not my default data connection or wlan.

Please use plain text.
Counsellor
Alexr71
Posts: 36

Re: N8 - MMS access point issues

 


piecafe wrote:

How can I change/delete an automatically configured "Vodafone MMS" access point setting?

 


 

You can't.

Alex.

Please use plain text.
Counsellor
drandywright
Posts: 71

Re: N8 - MMS access point issues

Can't you manually create a new one, and change that to the default (even if you can't remove the preconfigured one) ?

 

I am not sure myself as i bought a SIM-free handset as was fed up with having to de-brand my phones so i got the firmware updates on time and non-modified.  But ON mine, O2 sent the configuration settings when i put the SIM in, but I can delete them.

Please use plain text.
Contributor
Posts: 6

Re: N8 - MMS access point issues

 


drandywright wrote:

Can't you manually create a new one, and change that to the default (even if you can't remove the preconfigured one) ?

 

I am not sure myself as i bought a SIM-free handset as was fed up with having to de-brand my phones so i got the firmware updates on time and non-modified.  But ON mine, O2 sent the configuration settings when i put the SIM in, but I can delete them.


 

Yes, I can manually create a new one (or ask Vodafone to send me a configuration SMS for prepay), and I have done this within the Messaging application to get MMS to work. However, something is still trying (and failing) to use the bad "Vodafone MMS" access point every 60 seconds.

 

I have tried stopping all applications, removing all widgets from my home screen (which is in offline mode, anyway) and restarting the phone, but still something tries to connect. The only way I can stop my phone spamming the network with failed connection attempts is to turn of network data all together.

 

BTW, this is a SIM-free handset, into which I first placed an O2 prepay, and then a Vodafone prepay SIM.

Please use plain text.
Counsellor
drandywright
Posts: 71

Re: N8 - MMS access point issues

It must be storing the connection settings in multiple places on the phone (I must say i find the connections setting very complex as there are so many menus)

 

Hve you checked the APN settings under Settings/connectivity/settings/APN ?

 

 

Please use plain text.
Registered Member
mcgiffin
Posts: 1

Re: N8 - MMS access point issues

Piecafe,

 

The APNs used by Media Messaging don't seem to show up on the Network Destinations menu. I think they are in a "hidden" destination called MMS, which you cannot get to. I have worked out a solution which involves creating a new APN for MMS and then sticking it into a new destination ("Media Messaging"). You can then tell the Messaging system to use your new MMS APN instead of  using the VF MMS one. See here:

 

http://community.giffgaff.com/t5/Help-Ask-the-community-got-stuck/giffgaff-ing-a-Nokia-N8/td-p/12363...

 

If you know the settings you want to use for your MMS APN you should be able to adapt these instructions. It worked for me using Giffgaff, who are an MVNO on the O2 network.

 

- mcgiffin

Please use plain text.
New Member
megabyte1986
Posts: 2

Re: N8 - MMS access point issues

I was having the same problem, but with a different access point, and I founded the solution by mistake. If you want to delete an access point follow this steps:

Menu -> Settings - >Connectivity -> Settings -> Destinations -> <the destination where is stored your access point> -> <press and hold on the access point that you want to erase until it pops-up a sub-menu that has the option "Delete">.

 

I hope this solved your issues.

Please use plain text.
Advisor
Posts: 23

Re: N8 - MMS access point issues

[ Edited ]

I was experiencing the exact same problem. I tried everything to stop the phone constantly accessing the Vodafone MMS access point.

I was experiencing the exact same problem. I tried everything to stop the phone constantly accessing the Vodafone MMS access point.

 

 

I can't be 100 percent sure this is what fixed the problem, but I'm sure it's the last thing I did before the access attempts stopped.

I was experiencing the exact same problem. I tried everything to stop the phone constantly accessing the Vodafone MMS access point.

 

 

I can't be 100 percent sure this is what fixed the problem, but I'm sure it's the last thing I did before the access attempts stopped.

 

I created a new GPRS access point (with a working APN), and tried to rename it to "Vodafone MMS", I got an error saying Vodafone MMS already existed (despite it not showing up in any of the configuration screens), I canceled the rename and deleted the AP I'd  created.

I was experiencing the exact same problem. I tried everything to stop the phone constantly accessing the Vodafone MMS access point.

 

 

I can't be 100 percent sure this is what fixed the problem, but I'm sure it's the last thing I did before the access attempts stopped.

 

I created a new GPRS access point (with a working APN), and tried to rename it to "Vodafone MMS", I got an error saying Vodafone MMS already existed (despite it not showing up in any of the configuration screens), I canceled the rename and deleted the AP I'd  created.

 

I was experiencing the exact same problem. I tried everything to stop the phone constantly accessing the Vodafone MMS access point.

 

 

I can't be 100 percent sure this is what fixed the problem, but I'm sure it's the last thing I did before the access attempts stopped.

 

I created a new GPRS access point (with a working APN), and tried to rename it to "Vodafone MMS", I got an error saying Vodafone MMS already existed (despite it not showing up in any of the configuration screens), I canceled the rename and deleted the AP I'd  created.

 

 

Sounds unlikely I know, but I'm sure this fixed by problem,

I was experiencing the exact same problem. I tried everything to stop the phone constantly accessing the Vodafone MMS access point.

 

 

I can't be 100 percent sure this is what fixed the problem, but I'm sure it's the last thing I did before the access attempts stopped.

 

I created a new GPRS access point (with a working APN), and tried to rename it to "Vodafone MMS", I got an error saying Vodafone MMS already existed (despite it not showing up in any of the configuration screens), I canceled the rename and deleted the AP I'd  created.

 

 

Sounds unlikely I know, but I'm sure this fixed by problem,

 

SJ

Please use plain text.
Advisor
Posts: 23

Re: N8 - MMS access point issues

Sorry about the strange duplication in the above post, it's not me - It must be a bug with the site.

Sorry about the strange duplication in the above post, it's not me - It must be a bug with the site.

 

 

SJ

Please use plain text.
Advisor
frisbi
Posts: 11

Re: N8 - MMS access point issues

hi fellow N8 users,

 

very comparable situation drove me crazy. I have some hidden MMS setting from my provider "Base". I found a way to circumvene the situation for at least a some of the applications...

Solution

-I added a "New  Destination" which I called "i".

-I added my usual Access points under this "i" (i.e. first some WLAN and then my correct data connection settings).

- I made "i" the default Destination

- for some applications I als changes Destination to "i", e.g. for the standard N8 browser

Observations/Consequence... 

- this solved situation for e.g. standard browse, which made me very happy

- It doens't solve situation for Ovi Maps:smileysad:

- few applications use the default status which I gave to destination  "i" :smileysad:

- very interesting is Opera Mobile 10... there you can set the connection via Advanced Settings - you can not select a destinatio though:smileysad: - and hohoho... there I can actually see the hidden "BASE MMS" connection...

 

Conclusion : I now understand the problem fully and found workaround for some applics

Let me know if this helps you... and if you can still improve this approach further!!

FJ

Please use plain text.
Contributor
Posts: 6

Re: N8 - MMS access point issues

I'm afraid I can't offer any more ideas about the last post, but it was with some relief that I eventually stumbled upon an apparent solution for my original problem...

 

 "How can I stop the N8 from trying to connect to this access point every 60 seconds, without disabling network data completely?"

 

It occured to me a couple of weeks ago that if the problem was an incorrect, hidden, automatically configured MMS access point then perhaps I could perturb it by swapping my Vodafone SIM for an O2 one.

 

So, with the Vodafone SIM, I was seeing the strange attempts to connect to the wrong Vodafone MMS access point. I swapped it for an O2 SIM and these attempts stopped (and weren't replaced by any attempts to connect to O2). I put my Vodafone SIM back in and (fingers crossed) I haven't seen any sign of the attempts to connect to the Vodafone MMS access point - neither in the connection status icon nor the connection log.

 

Both MMS and data connections are now working fine for me, albeit with manually configured definitions for the Vodafone PP access points.

Please use plain text.
Counsellor
ch4dwick
Posts: 35

Re: N8 - MMS access point issues

Same problem here. I guess there are 2 version of mms settings here. 1 is the one provided by the network. Sometimes this is automatically added once your phone is activated. The other is through manual addition.
Please use plain text.
New Member
Kris125
Posts: 2

Re: N8 - MMS access point issues

Sorry, but no - it is not "Solved!"

What is semi-described below is by no means a solution. And at any rate - it does not work for me.
From different posts I see that the only real solution is an intervention of the service provider, which unfortunately my provider is unwilling (or unable?) to do.
So what we need is Nokia fixing the software so the users have control over the MMS access point the same way like we have control over access point for the internet connection.
Please use plain text.
Advisor
vaneedar
Posts: 15

Re: N8 - MMS access point issues

Hi,

Solution is correct, it happend with me and i change sim to other operator and mms connection disappeared. But you should always change settings/application settings/positioning/position server/serversettings/access point ==> set to "Internet" not to "mms"!!

+ call provider and ask to block mms connection.

Vaneedar

Please use plain text.
New Member
Kris125
Posts: 2

Re: N8 - MMS access point issues

Here is what finally worked for me:

 

Settings->connectivity->settings->destinations

 

I created new destination with "Options->New Destinations" called "Media messaging". Within this group I defined (Options->New acces point) an access point for the MMS for my current provider. Current setting name was just MMS so I created a different name to know what to select later. Names with spaces or underscore did not seem to be accepted, so I named it MMS-W. 

 

Then again Settings->Connectivity->Settings->APN Control (changes here required PIN2)

 

I have removed the incorrect MMS settings (tap on MMS and hold, then tap on Remove)

Then - "Options->Add name manually" - this allowed me to add the new MMS setting I just created (the MMS-W).

 

Back out of all the settings.

 

Go to Messaging.

In Messaging: Options->Settings->Mutltimedia message.

Select "Access Point in Use". Here I finally was able to see the new access point I have just defined not only the old one. 

Select the correct access point (in my case it was MMS-W).

 

I have rebooted the phone somewhere during the process, but don't quite remember where. I suppose it will not hurt if you reboot it after all the changes are done if without the reboot this will not work.

Please use plain text.
Counsellor
Posts: 30

Re: N8 - MMS access point issues

Hi to everyone,

 

I own an original, unlocked European N8 (Italy).

 

I live in Japan and I use the Softbank carrier. I have all the correct settings for both the MMS and internet access (under the unlimited data plan) even though the carrier does not like these settings to be known, I am 100% sure that they are correct.

 

These settings are very detailed but on my N8 I don't have the same menu options. Specifically I cannot find the following input options for the Internet AP:

  • Proxy:
  • Port:
  • Server:
  • MMSC:
  • MMS:
  • MMS:
  • MCC:
  • MNC:
  • APN type:

And I cannot find these input options for the MMS AP:

  • Proxy:
  • Port:
  • Server:
  • MMSC:
  • MMS proxy:
  • MMS port:
  • MCC:
  • MNC:
  • APN type:

Also, when I try to access the APN Control menu I receive "SIM card error" (with ANY SIM card from ANY carrier, Softbank included) and I cannot access either option (Activate Restrictions or Add name manually).

 

I can receive MMS but I cannot send them. I receive an error message: "message refused by server".

 

I am not so sure about internet, yet, but I will update once I receive my monthly bill (fingers crossed).

 

Can anyone, PLEASE, help me?

 

I am more and more lured into buying an Android (Desire HD) which my friend has managed to set with much greater ease even though it was locked on another carrier...!

:-(

But before I give up and I take the Android plunge I really wish to have a last shot at it... PLEASE, any help?

 

TIA for reading thus far and investing your time/expertise to whom will try to help me.

 

Tommaso

Please use plain text.
Advisor
freepizza
Posts: 15

Re: N8 - MMS access point issues

[ Edited ]

Not sure if it already discussed....

To temp disable APN's (is reversible so ok and configuration is not lost) ->

 

 

Now apply a block on certain APN's.

 

settings->connectivity->settings->APN control->Options->Activate restrictions 

Then from the same point

Options->Add name manually->[pin for sim]->Put the name of the apn in that you want to use NOT the MMS one. Or keep it blank so NO apns are used, so no 3G data is allowed. By doing this you cannot send MMS messages until the restrictions are removed.

 

Now MMS will not connect but it is reversible by Deactivating APN control. You can use wireless while this is on.


Extra stuff - What if  'wireless always on':

 

Go to

 

Menu->Applications->Mail->Settings->Synchronisation->change the retreival frequency to every 4 hours for all email accounts. Also the scedule to daytime hours. I had the wireless on continuously with email. Check your other apps. Also use the priority method explained earlier if that suits you.

 

If you want to keep you wireless key and stuff but not use the connection. Make a destination called ignore. Move the wireless connection to there.

 

Please use plain text.
Registered Member
SIR_IP
Posts: 2

Re: N8 - MMS access point issues


Settings -> Connectivity -> Settings -> Destinations -> Access point -> No to auto check for available access points -> Packet data -> enter name of your new APN ie. MMS 2 -> Internet -> click on newly made access point -> change name to mms.windmobile.ca and homepage to http://mms.windmobile.ca -> next click Options -> Advanced settings -> Proxy server address 74.115.197.70 -> Proxy port number 8080

 

THIS SETTINGS ARE FOR WINDMOBILE USERS ONLY ! BUT IF YOU GET THESE SETTINGS FROM YOUR COMPANY YOU WILL BE ABLE TO CHOOSE BETWEEN (NONE,MMS,MMS 2)

HOPE THIS WORKS FOR YOU IT WORKED FOR ME .

Please use plain text.
Counsellor
Posts: 30

Re: N8 - MMS access point issues

@SIR_IP, freepizza

I tried what you guys suggest.

 

The problem is that my N8 will not allow ANY SIM card to access the APN Control menu while my N97 allows alomst all the same SIM cards to access the APN Control (except the smartphone Softbank SIM card)as long as I input the correct PIN number.


My N8 is a regularly unlocked, official Nokia N8... like the N97

 

In any case, I have NO problem to create, delete and chose any access point that I like. This is not the problem.

 

Maybe the problem is that I cannot input all the settings which I listed in my previous post. Maybe. I'm not sure...

 

What is sure is that with this N8 I cannot access the APN Control menu with any card, but I can send MMS with my Italian SIM card. I can also access the internet correctly (I checked my bill this month, so I'm sure that accessing the internet is ok).

I only cannot send MMS. Receive yes, Send no.

 

Thank you for your time and expertise, it is much appreciated! Really, I'm going mad!

Please use plain text.