Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Re: 5530XM, Nokia (Ovi) Maps 3.0 and Certificate E...

Contributor
Posts: 5

N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

I'm currently trying to instal Nokia Maps 3 onto my N95, and every time it reaches the install point the phone throws out the error "Certificate Error: Please Contact the software provider"

 

I was wondering if anyone can give me a hand with this, I have seen a few posts about this error on the boards yet no one has given a solution, I have checked my application settings and can't see any reason why it is failing to install over my current version which is v1.2 wk37 b05

 

I want to eventually buy more maps but I refused too until I have the latest version installed

 

Any solutions would be most helpful

Please use plain text.
Advisor
ReTek
Posts: 20

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

got the same here on my 5530XM

 

20.0.080.C02.01 is the SV 

 

something about licence not yet in use ("nog niet geldig" [phone is in dutch :smileyhappy: ]) or expirer.

 

So please give use a hand, i really would like to use the phone without problems :smileyhappy:

Nokia 5530XM V30.0.009
Please use plain text.
Sage
zomgdude
Posts: 175

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

maybe it has something to do with the new year? probably the certificate is set to expire before 2010.. try and manually set the phone's time and date to something like 2009 / december 1st, and see if the installer works..
If, from time to time, I actually give a good advice, please click on the Kudos icon, I have cookies and free hats!
Please use plain text.
Advisor
ReTek
Posts: 20

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

i already tried that, and it still doesn't want to :/
Nokia 5530XM V30.0.009
Please use plain text.
Sage
zomgdude
Posts: 175

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

have you restarted your phone after changing the date? are you using ovi suite for installing ovi maps, or just opening a .sis on your phone?
If, from time to time, I actually give a good advice, please click on the Kudos icon, I have cookies and free hats!
Please use plain text.
Advisor
ReTek
Posts: 20

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

i'll give restarting a try :smileytongue:

 

using the suite :smileyhappy:

Nokia 5530XM V30.0.009
Please use plain text.
Sage
zomgdude
Posts: 175

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

you could try installing it with this software, as well, if it won't work after restarting the phone : http://nds1.nokia.com/files/support/global/phones/software/Setup_Nokia_Maps_Updater_1.0.12.exe
If, from time to time, I actually give a good advice, please click on the Kudos icon, I have cookies and free hats!
Please use plain text.
Advisor
ReTek
Posts: 20

Re: 5530XM, Nokia (Ovi) Maps 3.0 and Certificate Errors

Nope still the same when i restarted the phone :/

 

i got it almost in the maploader i think.

 

he detect the phone >> but only wants to install on the phone memory (why not on the SD)

so iff we could solve that we are already 1 step further

Nokia 5530XM V30.0.009
Please use plain text.
Sage
zomgdude
Posts: 175

Re: 5530XM, Nokia (Ovi) Maps 3.0 and Certificate Errors

[ Edited ]

no idea on that, try installing it on the phone's memory, see if it works. at least so you'll know if there's something wrong with the maps kit or with ovi suite.

 

L.E.: try copying this file on your memory card, and installing it from there: http://www.n97geeks.com/Nokia_Maps_3.01_2401_5.0_u.sis (it's the nokia maps install kit, directly to the phone, so no ovi suite bugs will interfere)

Message Edited by zomgdude on 03-Jan-2010 12:02 AM
If, from time to time, I actually give a good advice, please click on the Kudos icon, I have cookies and free hats!
Please use plain text.
Contributor
Posts: 5

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

First off let me startt by thanking Retek for hijacking my post

 

secondly i have tried updating via both the maps updater and via ovi suite neither of which work, both result in the same error message, this is not related to the new year as i've had this problem for months but only just got round to posting ahelp query

 

Also note that the error is not about an expired cerficiate (that's caused by having an incorrect date on your device) it is a incorrect certificate

Please use plain text.
Advisor
ReTek
Posts: 20

Re: 5530XM, Nokia (Ovi) Maps 3.0 and Certificate Errors

Thx for all the help man, i found it myself just before i went to bed. so everything works now :smileyhappy:

 

iff there are certificate problems you can see the date when you can use them, so iff you set your it it wil be ok.:smileyhappy:

 

also i found out my date wasn't 2/1/2010 but 2/1/2009 (stupid i know)

but now everything works :smileyhappy:

 

thx again, u get some kudos from me :smileyhappy:

Nokia 5530XM V30.0.009
Please use plain text.
Sage
zomgdude
Posts: 175

Re: 5530XM, Nokia (Ovi) Maps 3.0 and Certificate Errors

[ Edited ]

you're welcome, glad i could help, thanks for the kudos! :smileyhappy:

majikthise, have you tried installing ovi maps from that link, too? if so, do you get the same error?

also, have you checked the two settings in the apps manager? ( Menu - Tools - Settings - Applications - App Manager - Install apps: ALL & Check online certif...: Disabled)

Message Edited by zomgdude on 03-Jan-2010 11:02 PM
If, from time to time, I actually give a good advice, please click on the Kudos icon, I have cookies and free hats!
Please use plain text.
Contributor
Posts: 5

Re: 5530XM, Nokia (Ovi) Maps 3.0 and Certificate Errors

I as I have already stated it is not a time issue, there is a problem with the certificate, also the sis file you uploaded is incompatable with the N95 it gives it as a error when I try to install it, also the setting are as you have posted

 

I have tried installing maps via the updater, and via ovi suite both give the same error "Certificate Error. Contact the application supplier" on the phone, Nokia Maps Updater gives, "Can not update the maps application. The installation failed or was cancelled on the phone (18)."  I can't even see the certificate details, I can see them on the sis file that you uploaded zomg but not on the ones downloaded via Nokia Maps Updater or Ovi Suite

Please use plain text.
New Member
Posts: 3

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

I had the same certificate problem in my 5800 and i can fix it uninstaling all the nokia software i have in my pc (pc suite, map loader, maps updater, software updater . ....) and after that i install the Nokia Ovi suite (nothing else). First i reinstal the phone software( just in case, not sure if it was necesary) and then went to the software updater again (always with Ovi suite) and upgrade the Maps 2.0 to 3.0 with no problem. I did it today
Please use plain text.
Contributor
Posts: 5

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

see, Ok let's see. tried with only Ovi installed, after wiping and reinstalling latest firmware, again same error and I'm still stuck with maps 1.0 and now i need to reinstall all my software again

 

any more ideas just to point out for all you people who keep going on about the 5800 I am on a N95 they are different versions of Symbian. 5800 is S60 5ed and N95 is S60 3ed FP1 they are not the same

Please use plain text.
Registered Member
Posts: 1

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

Hi Majikthise, i have exactly the same problem as you have - I have a Nokia N95 phone (i updated the phone software like Nokia care line advised, and I tried to install the Nokia Maps Updater and I keep getting the same errror message right at the last point of installing: Certificate Error. Contact Application Supplier).

 

I am extremely frustrated and angry that Nokia technicians cant seem to help or even know what the heck is the matter with this.

Please use plain text.
Registered Member
Posts: 3

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

Have you tried updating the N95 phone software? Had the same certificate problem. But now resolved after updating phone software using Ovi suite.
Please use plain text.
Contributor
Posts: 5

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

I am having the same problem on both ovi and with the nokia updater, before people point out that having them both installed might be the problem I assure you it isn't as they are on different machine and I have tried to get it installed on a few different machines.

 

The major problem is nokia don't release the sis files any more, if I could get my hand on it I could use the SDK to look at the certificate and maybe resign it to fix it but it's not there for me to look at so I can't even see if it is a certificate problem, and Nokia's answer of "try a newer phone" doesn't really help when I don't have the money or want to upgrade my handset just to get maps working on a serported device

Please use plain text.
New Member
Posts: 2

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

same certificate error here with 6110 Navigator.

You can get the sis File from http://nds1.nokia.com/PRODUCT_METADATA_0/Explore_Services/Ovi_Maps/maps_installer_3.03_10wk1_b05_s60... , would be great if you could look into it and find a fix :smileyhappy:

Please use plain text.
New Member
operalover
Posts: 3

Re: N95, Nokia (Ovi) Maps 3.0 and Certificate Errors

Hello. I own a N76 that had nokia maps 1.2 preinstalled and has the latest firmware. Had lots of trouble trying to install the 2.0 or 3.0 version, because it didn't work either by using the ovi suite (latest version) or the map updater (both .10 or .12 versions). Both programs kept saying that I could upgrade to 3.0 but they were unable to install and the same error you get was displayed in my phone and pc software. I tried different versions of nokia maps, starting with the "official" and latest one, but they didn't work until I find the version "Nokia_Maps_2.0_2102_3.1_u.sis" that finally worked. Tried again with map updater and ovi suite to get 3.0 now that I had the 2.0 but I got the same error...so I kept trying with different versions of 3.0 until I found this one: Nokia_Maps_3.01_2602_3.1_u.sis (just google it and get it somewhere). That finally worked and now I have 3.0. Probably not the latest version...but I least is working, until the day I decide to try the hard reset and start from scratch.
Please use plain text.