Search Discussions:
Showing results for 
Search instead for 
Do you mean 
Advanced Search...
Welcome to Nokia Support Discussions! Here you can share advice and tips with thousands of other Nokia users around the world in English. Many Nokia employees also follow and participate in the discussions, see our guidelines for more information. Everyone can search and read the discussions, but to post your own question or reply to others, simply sign in with your Nokia account. If this is your first time here, you can choose an alias to represent you. And if you don't have a Nokia account yet, please register.
Reply

Nokia 5800 Wifi connect problem

New Member
Posts: 1

Nokia 5800 Wifi connect problem

My Nokia 5800 displays my Thompson Router with an active connection, but once I try to connect to the internet and check my email I get a display warning that states, "Web: no gateway reply."

 

My router is set to WPA/PSK. My Nokia N95 worked fine with these settings, but I can't connect to the internet with the same settings on my new Nokia 5800.

 

Any thoughts?

 

Thanks.

 

JR

Please use plain text.
Counsellor
timou
Posts: 88

Re: Nokia 5800 Wifi connect problem

[ Edited ]

Hi,

 

m3rl got it working with Thompson by disabling WMM. You'll need to open telnet (command line interface) session to your router, from there you'll be able to disable WMM, see here:

 

/discussions/board/message?board.id=connectivity&view=by_date_ascending&message.id=22011#M22011

Message Edited by timou on 02-Mar-2009 10:43 AM
_________________________________________________
2110i | 3110 | 6110 | 6210i | 9210i | N95
Please use plain text.
New Member
Posts: 1

Re: Nokia 5800 Wifi connect problem

Hello people !!

 

First of all your router should be set to WEP and don't forget your WEP key.

 

1. Go to MENU

2. Connectivity

3. Destinations

4. Internet (priority #1) <<<<--- wifi access blah blah blah router whatever

5. options

6. edit

7. WLAN Security Settings

8. change

9. WEP key settings

10. Change WEP key <<<<-- this WEP key is the same as your Router's WEP key

11. EXIT

12. Start Web Browsing

 

I hope this helped people who are in trouble connecting thier nokia 5800 on wifi. Send me an email if you have further querries.

 

Best Regards to all !!!

 

Please use plain text.
New Member
axer_don
Posts: 2

Re: Nokia 5800 Wifi connect problem

[ Edited ]

hey..hows ur nokia 5800..i guess everybody is wrong..i just got my new 5800 a while ago connected to my wireless router and i want it it to share with u.. the secret is ...the GATEWAY..u must know the ip address and subnet mask of ur desktop computer and gateway of ur router..do this tru ryt click on ur icon of ur wireless network connection on the lower ryt corner of ur screen..then click status..click support...did u see ur default gateway?

 

now go and set up the following on ur fone 

  1. menu
  2. settings
  3. connectivity
  4. destination
  5. internet
  6. choose ur router's name (be sure that ur fone is disconected to ur router while on this set up)
  7. options
  8. edit
  9. options
  10. advance settings
  11. IPv4 settings
  12. phone ip address
  13. switch from automatic to defined settings
  14. for example ,the ip address of ur desktop computer is 192.168.1.102, make ur fone ip address to be 192.168.1.103
  15. then copy the subnet mask and the default gateway of ur desktop computer.. ex. subnet mask = 255.255.255.0          default gateway = 192.168.1.1
  16. done

You can now connect to ur wireless router...the moment ur already connected,u can now start surfing the net...

 

that's all folks...

 

-aXerdon-

Message Edited by axer_don on 20-May-2009 07:41 PM
Message Edited by axer_don on 20-May-2009 07:42 PM
Please use plain text.
Registered Member
Posts: 1

Re: Nokia 5800 Wifi connect problem

 hi there axer don

 i was able to connect to my wireless router but there is another issue. when i have to access internet from my laptop i have to provide a user name password provided by my isp. how can i configure my nokia 5800 to do the same .

 

i. connect to the wifi (this part is working ok)

ii. when connected ask for username password of the isp provider to access internet.

 

to be more specific i live in india and i am using BSNL internet connection and using there hawaii wi fi router. 

Please use plain text.
Registered Member
Posts: 1

Re: Nokia 5800 Wifi connect problem

VBRENTLY---------------------------------------->>>>>>>>

THANK YOU THANK YOU THANK YOU THANK YOU....DONE EXACTLY WHAT YOU ADVICED...AND ITS ALL SORTED!!! GOD BLESS YOU AND A TRILLION KUDOS TO YOU!!!!

Please use plain text.
Registered Member
Posts: 1

Re: Nokia 5800 Wifi connect problem

its not working
Please use plain text.
Registered Member
charan_theja
Posts: 1

Re: Nokia 5800 Wifi connect problem

hi can seome one please tell me how to connect ti wifi in 5800. I have tried all the settings, i gave my PC ip address now it is showing as known network but when try yo open some site it is showing wlan not found
Please use plain text.
New Member
axer_don
Posts: 2

Re: Nokia 5800 Wifi connect problem

hey..hows ur nokia 5800..i guess everybody is wrong..i just got my new 5800 a while ago connected to my wireless router and i want it it to share with u.. the secret is ...the GATEWAY..u must know the ip address and subnet mask of ur desktop computer and gateway of ur router..do this tru ryt click on ur icon of ur wireless network connection on the lower ryt corner of ur screen..then click status..click support...did u see ur default gateway? now go and set up the following on ur fone 1.menu 2.settings 3.connectivity 4.destination 5.internet 6.choose ur router's name (be sure that ur fone is disconected to ur router while on this set up) 7.options 8.edit 9.options 10.advance settings 11.IPv4 settings 12.phone ip address 13.switch from automatic to defined settings 14.for example ,the ip address of ur desktop computer is 192.168.1.102, make ur fone ip address to be 192.168.1.103 15.then copy the subnet mask and the default gateway of ur desktop computer.. ex. subnet mask = 255.255.255.0 default gateway = 192.168.1.1 16.done You can now connect to ur wireless router...the moment ur already connected,u can now start surfing the net... that's all folks... -aXerdon-
Please use plain text.
Registered Member
Maddog9
Posts: 1

Re: Nokia 5800 Wifi connect problem

Hey Axer,

 

Thanks for the info so far.

 

I have got a connection going on but it keeps on coming back with : No Gateway reply.

 

As you mentioned this is the the key to setting this all up, what do i need to do??

 

cheers

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Wifi connect problem

Turn off the power saving in the advanced settings of WLAN.

‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Registered Member
sonu_009
Posts: 1

Re: Nokia 5800 Wifi connect problem

Thanks Its works for me...

 

i have problem in software update...

my version is 21.00 someting...

now already cross 41 ... i can't update my software.. can u help me please..?

Please use plain text.
Registered Member
sthamit
Posts: 1

Re: Nokia 5800 Wifi connect problem

guys, I had the same problem. What I did was I manually configured the ipaddress, gateway and DNS by copying the info from your computer cmd and it worked. make sure that the last 2 digit of the ip adress on your phone is different from that of computer. that's it. power off and then on and it's running. wow.....coooooool
Please use plain text.
Advisor
station2
Posts: 12

Re: Nokia 5800 Wifi connect problem

turn on the dhcp service on your router .
Please use plain text.
Contributor
emadgsk2006
Posts: 7

Re: Nokia 5800 Wifi connect problem

hello every body

i have 5800 device the problem that my device can't detect the wirless network in my area easly and rarly when it detect wirless network it cann't connect to it and says network lost

and the wirless network name disappear from my 5800 device

i made an access point with my name and i entered the ip adress ( different from my pc )

but where i can add  the default gatway no. and subnet mask no. in my ipv4 mode i onely found Dns addresses and i entered its no. in it

 

and what is the use of making access point while my phone can't detect the wirless network name at all............pleeeease help

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Wifi connect problem

IP4 config is not advised. Set your 5800 to automatic. Let router DHCP do it's work. However, if you use fixed IP, enter IP, a new screen will be opened to continue for Subnet, Default Gateway and DNS server settings. Turn off power saving in the advanced settings of WLAN.

‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Registered Member
floptheshot
Posts: 1

Re: Nokia 5800 Wifi connect problem

hi there i have followed the instruction you posted but i am still unable to get the connection to my netgear router? please help

Please use plain text.
Contributor
emadgsk2006
Posts: 7

Re: Nokia 5800 Wifi connect problem

thank u hadimassa

but  1. my 5800 can't detect the wireless network

 2. if 5800 detect it (rarly) it can't connect to it and it disappears again

3. other devices like n95 connect easly to it

 4. when i make access point and enter the ip address of the phone nothing appear like subnet mask and default getway only the dns ip

5.  where is the power saving option ? , is it in the phone or the wireless network itself ?

and if the power saving option is in the wireless network  what is the use of turnning it off?

    

Please use plain text.
Mobile Guru
hadimassa
Posts: 4,790

Re: Nokia 5800 Wifi connect problem

Did you reset the router and enabled SSID?

‡Thank you for hitting the Blue/Green Star button‡

N8-00 RM 596 V:111.030.0609; E71-1(05) RM 346 V: 500.21.009
Please use plain text.
Contributor
emadgsk2006
Posts: 7

Re: Nokia 5800 Wifi connect problem

what is the ssid and what is the use of turnning off the poswer saving and enabeld the ssid thing? thanks

Please use plain text.